summaryrefslogtreecommitdiff
path: root/community/elasticsearch/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/elasticsearch/PKGBUILD')
-rw-r--r--community/elasticsearch/PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/community/elasticsearch/PKGBUILD b/community/elasticsearch/PKGBUILD
index 491d2141e..4dd160cb4 100644
--- a/community/elasticsearch/PKGBUILD
+++ b/community/elasticsearch/PKGBUILD
@@ -1,25 +1,31 @@
-# $Id: PKGBUILD 115776 2014-07-16 12:44:51Z mtorromeo $
+# $Id: PKGBUILD 116201 2014-07-23 21:31:20Z mtorromeo $
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
# Contributor: Marcello "mererghost" Rocha <https://github.com/mereghost>
# Refactored by Blaž "Speed" Hrastnik <https://github.com/archSeer>
pkgname=elasticsearch
-pkgver=1.2.2
-pkgrel=2
+pkgver=1.3.0
+pkgrel=1
pkgdesc="Distributed RESTful search engine built on top of Lucene"
arch=('i686' 'x86_64')
url="http://www.elasticsearch.org/"
license=('APACHE')
-depends=('java-runtime' 'bash' 'systemd')
+depends=('java-runtime' 'systemd')
install='elasticsearch.install'
source=(
"http://download.elasticsearch.org/$pkgname/$pkgname/$pkgname-$pkgver.tar.gz"
elasticsearch.service
elasticsearch@.service
- elasticsearch-user.conf
elasticsearch-sysctl.conf
+ elasticsearch-tmpfile.conf
elasticsearch.default
)
+sha256sums=('4e2cf72d4ceaaf250a292c00a320d13d2fdb067ad8aeed969862db3060af4534'
+ 'f3a6e5b968ffe38edc42c80193f75ab1682a5224c977c8957816d321733aabc4'
+ 'c3ea4d82da44da8ea9bcb4d7d9cdfb086d25fd8ec2ea457adec290f0d6ebe083'
+ 'b3feb1e9c7e7ce6b33cea6c727728ed700332aae942ca475c3bcc1d56b9f113c'
+ '39ab5801b45c0f49af43c4d1826a655a981bfa07e4b3791d7a0719f8c191d8d9'
+ 'a0ee0761156a02d3f79db5ef295613c1a6d4267482c8db889d92a94b59feb497')
backup=('etc/elasticsearch/elasticsearch.yml'
'etc/elasticsearch/logging.yml'
@@ -69,17 +75,10 @@ package() {
install -Dm644 "$srcdir"/elasticsearch.service "$pkgdir"/usr/lib/systemd/system/elasticsearch.service
install -Dm644 "$srcdir"/elasticsearch@.service "$pkgdir"/usr/lib/systemd/system/elasticsearch@.service
- install -Dm644 "$srcdir"/elasticsearch-user.conf "$pkgdir"/usr/lib/sysusers.d/elasticsearch.conf
+ install -Dm644 "$srcdir"/elasticsearch-tmpfile.conf "$pkgdir"/usr/lib/tmpfiles.d/elasticsearch.conf
install -Dm644 "$srcdir"/elasticsearch-sysctl.conf "$pkgdir"/usr/lib/sysctl.d/elasticsearch.conf
install -Dm644 "$srcdir"/elasticsearch.default "$pkgdir"/etc/default/elasticsearch
ln -s ../../../var/lib/elasticsearch "$pkgdir"/usr/share/elasticsearch/data
}
-
-sha256sums=('c833d000c7e29e17b4cc5df2e26020c159ee086cdf4ac19f661911cc9aedfbee'
- '4b7c741c2fa2f856cff6b9e83693c2de9d8c00a73812b34133b4446bdcb2e4c8'
- '0c6969af1ab91fc543d4c37fea8f3596872a143281c22a17801703490758ba0a'
- '51a5ebf06f8853b4b4cbf1b13320dd738a82e9f2caab47ca772f157a6bd78063'
- 'b3feb1e9c7e7ce6b33cea6c727728ed700332aae942ca475c3bcc1d56b9f113c'
- 'a0ee0761156a02d3f79db5ef295613c1a6d4267482c8db889d92a94b59feb497')