summaryrefslogtreecommitdiff
path: root/community/lmms/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lmms/PKGBUILD')
-rw-r--r--community/lmms/PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/community/lmms/PKGBUILD b/community/lmms/PKGBUILD
index d6b9c69a5..92e9b7674 100644
--- a/community/lmms/PKGBUILD
+++ b/community/lmms/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 109323 2014-04-13 11:20:12Z lfleischer $
+# $Id: PKGBUILD 116113 2014-07-22 16:03:04Z lfleischer $
# Maintainer: Lukas Fleischer <archlinux at cryptocrack dot de>
# Contributor: Shinlun Hsieh <yngwiexx@yahoo.com.tw>
# Contributor: Mateusz Herych <heniekk@gmail.com>
# Contributor: Storyteller <spiralsorrow@hotmail.com>
pkgname=lmms
-pkgver=1.0.0
+pkgver=1.0.3
pkgrel=1
pkgdesc='The Linux MultiMedia Studio.'
arch=('i686' 'x86_64')
@@ -23,18 +23,25 @@ provides=('lmms-extras')
conflicts=('lmms-extras')
options=('!makeflags')
install=lmms.install
-source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}-src.tar.bz2/download"
+source=("https://github.com/LMMS/${pkgname}/releases/download/v{$pkgver}/${pkgname}-${pkgver}-src.tar.bz2"
+ lmms-1.0.3-build-fix.patch
zynaddsubfx_unlink.patch)
-md5sums=('72260dd6e29bf018875fd751c1d43465'
+md5sums=('1f63ad9abd1781206d852e79b2191638'
+ 'fa8ab5c48b021b87f80444440479190a'
'd2ea78ac0cf2979505f140c6845617cf')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -Np1 -i ../lmms-1.0.3-build-fix.patch
+ patch -Np1 -i ../zynaddsubfx_unlink.patch
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
sed -i 's|lib64|lib|g' cmake/modules/DetectMachine.cmake
- patch -Np1 -i ../zynaddsubfx_unlink.patch
-
cmake . -DCMAKE_INSTALL_PREFIX=/usr -USE=vst
make
}