summaryrefslogtreecommitdiff
path: root/community/mythtv/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mythtv/PKGBUILD')
-rw-r--r--community/mythtv/PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/community/mythtv/PKGBUILD b/community/mythtv/PKGBUILD
index 888b269df..8c98823f0 100644
--- a/community/mythtv/PKGBUILD
+++ b/community/mythtv/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 108932 2014-04-07 19:24:35Z bgyorgy $
+# $Id: PKGBUILD 116360 2014-07-26 09:02:35Z fyan $
# Maintainer: Jonathan Conder <jonno.conder@gmail.com>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Juergen Hoetzel <juergen@archlinux.org>
@@ -6,18 +6,18 @@
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=mythtv
-pkgver=0.27
-pkgrel=8
+pkgver=0.27.3
+pkgrel=1
epoch=1
pkgdesc="A Homebrew PVR project"
arch=('i686' 'x86_64')
url="http://www.mythtv.org/"
license=('GPL')
-depends=('avahi' 'fftw' 'lame' 'libass' 'libavc1394' 'libcdio' 'libiec61883'
+depends=('avahi' 'fftw' 'lame' 'libass' 'libavc1394' 'libcdio' 'libiec61883' 'libgl'
'libpulse' 'libva' 'libvpx' 'libxinerama' 'lirc-utils' 'mariadb-clients'
'mysql-python' 'perl-dbd-mysql' 'perl-io-socket-inet6' 'perl-libwww'
'perl-net-upnp' 'python2-lxml' 'qtwebkit' 'taglib' 'urlgrabber' 'x264')
-makedepends=('glew' 'libcec' 'libxml2' 'mesa' 'mesa-libgl' 'openssl' 'yasm')
+makedepends=('glew' 'libcec' 'libxml2' 'mesa' 'mesa-libgl' 'openssl' 'yasm' 'x264-dev' 'gdb')
optdepends=('glew: for GPU commercial flagging'
'libcec: for consumer electronics control capabilities'
'libxml2: to read blu-ray metadata'
@@ -29,19 +29,16 @@ replaces=('myththemes' 'mythplugins-mythvideo')
install='mythtv.install'
source=("$pkgname-$pkgver.tar.gz::https://github.com/MythTV/$pkgname/archive/v$pkgver.tar.gz"
'mythbackend.service'
- 'http://code.mythtv.org/trac/raw-attachment/ticket/11338/libcec-2-support.2.patch'
- 'http://code.mythtv.org/trac/raw-attachment/ticket/12098/ticket12098-dont-load-lib-when-opengles-disabled.diff')
-sha256sums=('494ebd7ee384e751c05ee0a1b3dcd3618caf72f1e94810381c09c2b5d1c799f0'
+ 'http://code.mythtv.org/trac/raw-attachment/ticket/11338/libcec-2-support.2.patch')
+sha256sums=('8eaaf8c6e42ca6eb81f180467de90d597dbeabb1bb14b7085da353d2980db8f4'
'ecfde779ded8332cc62c86fac6b432b09cbf5d254135798287ada688af9a1302'
- '8270407c2074b305e0c32151f89c84f6bf980a32665a2da8e4727405fa3911f3'
- '55e9827ea8f5c685801c110f879825d1fb3006070e0318188a2fd55921b95bdf')
+ '8270407c2074b305e0c32151f89c84f6bf980a32665a2da8e4727405fa3911f3')
prepare() {
cd "$srcdir/$pkgname-$pkgver/$pkgname"
find 'bindings/python' 'contrib' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
patch -Np2 -i "$srcdir/libcec-2-support.2.patch"
- patch -Np2 -i "$srcdir/ticket12098-dont-load-lib-when-opengles-disabled.diff"
}
build() {