summaryrefslogtreecommitdiff
path: root/cross-mips64el-unknown-linux-gnu-gcc1/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-05-15 04:12:51 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-05-15 04:12:51 -0300
commit54dc83c0c9a791132cf88ad1513a810401fb57ab (patch)
tree8caefe5dbfd35b38ea09f5d99d2cd4af50746cd0 /cross-mips64el-unknown-linux-gnu-gcc1/PKGBUILD
parent3e794aedafd5b7f956a6d183c8c518988f875152 (diff)
cross-mips64el-unknown-linux-gnu-gcc1
Diffstat (limited to 'cross-mips64el-unknown-linux-gnu-gcc1/PKGBUILD')
-rw-r--r--cross-mips64el-unknown-linux-gnu-gcc1/PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/cross-mips64el-unknown-linux-gnu-gcc1/PKGBUILD b/cross-mips64el-unknown-linux-gnu-gcc1/PKGBUILD
new file mode 100644
index 0000000..8ecacb3
--- /dev/null
+++ b/cross-mips64el-unknown-linux-gnu-gcc1/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Nicolas Reynolds <fauno@kiwwwi.com.ar>
+#
+
+_pkgname=gcc
+_target=mips64el-unknown-linux-gnu
+_sysroot=/usr/lib/cross-${_target}
+
+pkgname=cross-${_target}-gcc1
+pkgver=4.5.3
+pkgrel=1
+pkgdesc="The GNU C Compiler for $_target stage1"
+arch=(i686 x86_64)
+makedepends=("cross-${_target}-binutils")
+source=(http://ftp.gnu.org/gnu/$_pkgname/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.bz2)
+
+build() {
+ cd $srcdir
+ export PATH="${_sysroot}/bin:$PATH"
+
+ unset CFLAGS CXXFLAGS
+
+ mkdir build
+ cd build
+
+ ../$_pkgname-$pkgver/configure \
+ --prefix=$_sysroot \
+ --target=$_target \
+ --disable-bootstrap \
+ --disable-nls \
+ --without-headers \
+ --with-newlib \
+ --disable-shared \
+ --disable-threads \
+ --disable-libssp \
+ --disable-libgomp \
+ --disable-libmudflap \
+ --enable-languages=c \
+ --without-ppl \
+ --without-cloog
+ make
+}
+
+package() {
+ cd $srcdir/build
+ export PATH="${_sysroot}/bin:$PATH"
+
+ make DESTDIR=$pkgdir install
+}
+md5sums=('8e0b5c12212e185f3e4383106bfa9cc6')