summaryrefslogtreecommitdiff
path: root/pkgs/perl-mouse
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2011-01-28 03:23:04 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2011-01-28 03:23:04 -0300
commit4fd38b1c7635719535ed16a2ed7cf6814ded90f8 (patch)
tree5a3adb6091fae6f777c4654663018715d04ab789 /pkgs/perl-mouse
parent21c6105c4fdacb617bd6a1cc06222f1de93be47e (diff)
updated README and [social] ABS treeHEADmaster
Diffstat (limited to 'pkgs/perl-mouse')
-rw-r--r--pkgs/perl-mouse/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/perl-mouse/PKGBUILD b/pkgs/perl-mouse/PKGBUILD
new file mode 100644
index 0000000..b41d53f
--- /dev/null
+++ b/pkgs/perl-mouse/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Justin Davis <jrcd83@gmail.com>
+# Generator : CPANPLUS::Dist::Arch 1.09
+pkgname='perl-mouse'
+pkgver='0.88'
+pkgrel='1'
+pkgdesc="Moose minus the antlers"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Mouse'
+source=('http://search.cpan.org/CPAN/authors/id/G/GF/GFUJI/Mouse-0.88.tar.gz')
+md5sums=('c086309d38bdc54450346439bcef6367')
+
+build() {
+ PERL=/usr/bin/perl
+ DIST_DIR="${srcdir}/Mouse-0.88"
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ { cd "$DIST_DIR" &&
+ $PERL Makefile.PL &&
+ make &&
+ make test &&
+ make install;
+ } || return 1;
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}