summaryrefslogtreecommitdiff
path: root/pkgs/social/monkeysphere
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2011-01-28 03:23:04 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2011-01-28 03:23:04 -0300
commit4fd38b1c7635719535ed16a2ed7cf6814ded90f8 (patch)
tree5a3adb6091fae6f777c4654663018715d04ab789 /pkgs/social/monkeysphere
parent21c6105c4fdacb617bd6a1cc06222f1de93be47e (diff)
updated README and [social] ABS treeHEADmaster
Diffstat (limited to 'pkgs/social/monkeysphere')
-rw-r--r--pkgs/social/monkeysphere/PKGBUILD23
-rw-r--r--pkgs/social/monkeysphere/monkeysphere.install40
2 files changed, 63 insertions, 0 deletions
diff --git a/pkgs/social/monkeysphere/PKGBUILD b/pkgs/social/monkeysphere/PKGBUILD
new file mode 100644
index 0000000..33c1bcf
--- /dev/null
+++ b/pkgs/social/monkeysphere/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: fauno <fauno@kiwwwi.com.ar>
+# Based on monkeysphere-git from
+# Contributor: Olivier Mehani <shtrom-arch@ssji.net>
+# $Id: PKGBUILD 264 2010-11-10 00:57:53Z shtrom $
+pkgname=monkeysphere
+pkgver=0.35
+pkgrel=1
+pkgdesc="Leverage the OpenPGP web of trust for OpenSSH and Web authentication"
+arch=('i686' 'x86_64')
+url="http://web.monkeysphere.info/"
+license=('GPL3')
+depends=('gnupg' 'lockfile-progs' 'perl-crypt-openssl-rsa' 'perl-digest-sha1')
+source=(http://archive.monkeysphere.info/debian/pool/${pkgname}/m/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz)
+install=monkeysphere.install
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+ mkdir -p $pkgdir/var/lib/monkeysphere
+}
+md5sums=()
+md5sums=('481ac14c9fdef0ccd1944c593bd4f517')
diff --git a/pkgs/social/monkeysphere/monkeysphere.install b/pkgs/social/monkeysphere/monkeysphere.install
new file mode 100644
index 0000000..cc31e72
--- /dev/null
+++ b/pkgs/social/monkeysphere/monkeysphere.install
@@ -0,0 +1,40 @@
+#!/bin/sh
+# $Id: monkeysphere.install 264 2010-11-10 00:57:53Z shtrom $
+# vim:set ts=2 sw=2 et:
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ echo ">>> Creating monkeysphere user and group and setting permissions..."
+ getent group monkeysphere >/dev/null || usr/sbin/groupadd monkeysphere
+ getent passwd monkeysphere >/dev/null || usr/sbin/useradd -c 'Monkeysphere WoT server identification tool' -g monkeysphere -d '/var/lib/monkeysphere' -s /bin/bash monkeysphere
+ chown monkeysphere:monkeysphere /var/lib/monkeysphere
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ usr/sbin/userdel monkeysphere &>/dev/null
+ (getent group monkeysphere >/dev/null && usr/sbin/groupdel monkeysphere &>/dev/null) || /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+