summaryrefslogtreecommitdiff
path: root/pkgs/statusnet
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2010-10-16 20:49:23 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2010-10-16 20:49:23 -0300
commit5422399c4feabb409b146b84f8a7dee12b38b983 (patch)
treeaa71477bf72d97625f8b39cfc4b503035b6dc95b /pkgs/statusnet
parent85f93c3d1343ffefa1164109a87c1eb40a14eb11 (diff)
Package directory. Here we'll put any PKGBUILD that is not on repos.
Diffstat (limited to 'pkgs/statusnet')
-rw-r--r--pkgs/statusnet/PKGBUILD47
-rw-r--r--pkgs/statusnet/statusnet.install13
2 files changed, 60 insertions, 0 deletions
diff --git a/pkgs/statusnet/PKGBUILD b/pkgs/statusnet/PKGBUILD
new file mode 100644
index 0000000..fd3f53c
--- /dev/null
+++ b/pkgs/statusnet/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: fauno <fauno@kiwwwi.com.ar>
+pkgname=statusnet
+pkgver=0.9.5
+pkgrel=1
+pkgdesc="StatusNet is a Free and Open Source microblogging platform."
+arch=('any')
+url="http://status.net"
+license=('AGPL')
+groups=('social-web')
+depends=('php>=5.2.3' 'mysql>=5' 'php-gd' 'php-curl' 'php-gmp')
+optdepends=('memcache: for caching database queries'
+ 'php-xcache: for accelerating PHP code execution')
+provides=()
+options=()
+source=("http://status.net/${pkgname}-${pkgver}.tar.gz"
+ statusnet.install)
+install=statusnet.install
+
+build() {
+ cd "$srcdir/$pkgname-${pkgver}"
+
+ etc_dir="${pkgdir}/etc/webapps/${pkgname}"
+ usr_dir="${pkgdir}/usr/share/webapps/${pkgname}"
+
+ install -d ${usr_dir}
+ install -d ${etc_dir}
+ install -d ${pkgdir}/usr/share/doc/${pkgname}/
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+
+ install -m644 ./{config.php,htaccess}.sample \
+ ${pkgdir}/usr/share/doc/${pkgname}/
+
+ install -m644 ./{README,EVENTS.txt,lighttpd.conf.example} \
+ ${pkgdir}/usr/share/doc/${pkgname}/
+
+ install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/
+
+ rm -f *.sample README COPYING README EVENTS.txt *.example
+
+ cp -ra * ${usr_dir}/
+ chmod a+w ${usr_dir}/
+ chmod a+w ${usr_dir}/{avatar,background,file}
+}
+md5sums=('ca4fc694e15c68cf921a9c2578988770'
+ '6f3de28ccb1385123bdf0eb66a78a875')
+md5sums=('ca4fc694e15c68cf921a9c2578988770'
+ '24991580625ec177c144ed5acdbe6dbc')
diff --git a/pkgs/statusnet/statusnet.install b/pkgs/statusnet/statusnet.install
new file mode 100644
index 0000000..4269344
--- /dev/null
+++ b/pkgs/statusnet/statusnet.install
@@ -0,0 +1,13 @@
+post_install(){
+ cat <<EOM
+StatusNet is now installed on your system.
+
+You should link /usr/share/webapps/statusnet to /srv/http/
+
+Start MySQL and your prefered webserver and visit
+http://yoursite.tld/statusnet/install.php
+
+Write permissions of /usr/share/webapps/statusnet has been granted to ensure the
+installation process can write the config file.
+EOM
+}