summaryrefslogtreecommitdiff
path: root/pkgs/lua-cyrussasl/lua-cyrussasl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/lua-cyrussasl/lua-cyrussasl.patch')
-rw-r--r--pkgs/lua-cyrussasl/lua-cyrussasl.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/lua-cyrussasl/lua-cyrussasl.patch b/pkgs/lua-cyrussasl/lua-cyrussasl.patch
new file mode 100644
index 0000000..5309e5a
--- /dev/null
+++ b/pkgs/lua-cyrussasl/lua-cyrussasl.patch
@@ -0,0 +1,37 @@
+diff --git a/Makefile b/Makefile
+index 9c696ab..37057da 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,12 +4,18 @@
+ #LUAPATH=/usr/share/lua/5.1
+ #CPATH=/usr/lib/lua/5.1
+
++# Linux (Arch Linux)
++CFLAGS=-g -O2 -fpic -I/usr/include
++LDFLAGS=-O -shared -fpic -lsasl2
++LUAPATH=/usr/share/lua/5.1
++CPATH=/usr/lib/lua/5.1
++
+ # MacOS
+-CFLAGS=-g -Wall -O2
+-LDFLAGS=-bundle -undefined dynamic_lookup -lsasl2
+-MACOSX_VERSION=10.5
+-LUAPATH=/usr/local/share/lua/5.1
+-CPATH=/usr/local/lib/lua/5.1
++#CFLAGS=-g -Wall -O2
++#LDFLAGS=-bundle -undefined dynamic_lookup -lsasl2
++#MACOSX_VERSION=10.5
++#LUAPATH=/usr/local/share/lua/5.1
++#CPATH=/usr/local/lib/lua/5.1
+
+ #########################################################
+ #
+@@ -26,7 +32,7 @@ OBJS=cyrussasl.o luaabstract.o context.o
+ all: $(TARGET)
+
+ install: $(TARGET)
+- cp $(TARGET) $(CPATH)
++ cp $(TARGET) $(DESTDIR)$(CPATH)
+
+ clean:
+ rm -f *.o *.so *~