summaryrefslogtreecommitdiff
path: root/pkgs/luaevent-prosody/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/luaevent-prosody/PKGBUILD')
-rw-r--r--pkgs/luaevent-prosody/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/pkgs/luaevent-prosody/PKGBUILD b/pkgs/luaevent-prosody/PKGBUILD
new file mode 100644
index 0000000..2dca1ab
--- /dev/null
+++ b/pkgs/luaevent-prosody/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Dwayne Bent <dbb.1@liqd.org>
+
+pkgname=luaevent-prosody
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Lua bindings for libevent library (Prosody fork)."
+arch=('i686' 'x86_64')
+url="http://code.matthewwild.co.uk/luaevent-prosody/"
+license=('LGPL2.1')
+depends=('libevent>=1.4' 'luasocket' 'lua>=5.1')
+provides=('luaevent')
+conflicts=('luaevent')
+source=("http://matthewwild.co.uk/uploads/$pkgname-$pkgver.tar.gz")
+md5sums=('070019926979ebb94b3383b17987502d')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make LUA_LIB="lua" DESTDIR="$pkgdir" install || return 1
+}
+