summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-lts-rt/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-08-12 16:55:47 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-08-12 16:55:47 -0300
commite6d283df6002f9577ab1646975de4a3212b9c3f1 (patch)
tree1e657e17ea17eb234488538e56ab5f0dffb026ce /kernels/linux-libre-lts-rt/PKGBUILD
parenta57ac99c53d4da8baf807722268aa60be4428111 (diff)
linux-libre-lts-rt-3.0.40_rt60-1: updating version
Diffstat (limited to 'kernels/linux-libre-lts-rt/PKGBUILD')
-rw-r--r--kernels/linux-libre-lts-rt/PKGBUILD112
1 files changed, 69 insertions, 43 deletions
diff --git a/kernels/linux-libre-lts-rt/PKGBUILD b/kernels/linux-libre-lts-rt/PKGBUILD
index 150353a14..277fac038 100644
--- a/kernels/linux-libre-lts-rt/PKGBUILD
+++ b/kernels/linux-libre-lts-rt/PKGBUILD
@@ -8,17 +8,15 @@
# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
-pkgbase=linux-libre-lts-rt
-pkgname=('linux-libre-lts-rt' 'linux-libre-lts-rt-headers') # Build stock -LIBRE-LTS kernel with RT support
-# pkgname=linux-custom # Build kernel with a different name
-_kernelname=-LIBRE-LTS-RT
+pkgbase=linux-libre-lts-rt # Build stock -LIBRE-LTS-RT kernel
+#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.0
-_releasever=39
-_rtpatchver=rt59
+_releasever=40
+_rtpatchver=rt60
_pkgver=${_basekernel}.${_releasever}
pkgver=${_basekernel}.${_releasever}_${_rtpatchver}
-_lxopkgver=${_basekernel}.39 # nearly always the same as pkgver
pkgrel=1
+_lxopkgver=${_basekernel}.39 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -30,7 +28,7 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
# the main kernel config files
'config.i686' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
- "${pkgname}.preset"
+ "${pkgbase}.preset"
'Kbuild'
'Kbuild.platforms'
'boot-logo.patch'
@@ -38,9 +36,12 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'i915-fix-ghost-tv-output.patch'
'ext4-options.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
+
+_kernelname=${pkgbase#linux-libre}
+_localversionname=-LIBRE-LTS-RT
md5sums=('5f64180fe7df4e574dac5911b78f5067'
- '9259948f76db87052be56da4c525d07a'
- '637deb8769ed9c0cb99ba2c8041a1d4b'
+ '4c42d5680df7921c20dda6f5fa44b275'
+ 'b7e3a739f569ecac90880624ab05ec6c'
'7266f5e7af09cc6e4b15d7a952e3b350'
'5387f0cf51652c071190789569adf9c7'
'85f04a9555bdc295f7c387a6564f0c81'
@@ -103,7 +104,7 @@ build() {
sed -ri -e "s|CONFIG_MIPS32_N32=.*|CONFIG_MIPS32_N32=y|g" \
-e "s|CONFIG_MIPS32_N32=.*|CONFIG_MIPS32_N32=y|g" \
-e "s|CONFIG_UEVENT_HELPER_PATH=.*|CONFIG_UEVENT_HELPER_PATH=\"\"|g" \
- -e "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" \
+ -e "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_localversionname}\"|g" \
-e "s;(CONFIG_USB(_COMMON|_EHCI_HCD|_OHCI_HCD|_STORAGE.*|_UAS)?)=.*;\1=y;g" \
./.config
else
@@ -111,7 +112,8 @@ build() {
fi
if [ "${_kernelname}" != "" ]; then
- sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" ./.config
+ sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_localversionname}\"|g" ./.config
+ sed -i "s|CONFIG_LOCALVERSION_AUTO=.*|CONFIG_LOCALVERSION_AUTO=n|" ./.config
fi
# set extraversion to pkgrel
@@ -131,15 +133,22 @@ build() {
#make oldconfig # using old config from previous kernel version
# ... or manually edit .config
+ # rewrite configuration
+ yes "" | make config >/dev/null
+
+ # save configuration for later reuse
+ if [ "${CARCH}" = "x86_64" ]; then
+ cat .config > "${startdir}/config.x86_64.last"
+ else
+ cat .config > "${startdir}/config.i686.last"
+ fi
+
####################
# stop here
# this is useful to configure the kernel
- #msg "Stopping build"
- #return 1
+ #msg "Stopping build"; return 1
####################
- yes "" | make config
-
# build!
if [ "$CARCH" == "mips64el" ]; then
# The build system passes it directly to linker, disable to avoid
@@ -147,21 +156,22 @@ build() {
export LDFLAGS=""
# bzImage is arch-specific and not supported on mips; vmlinux is
# useful for oprofile.
- make ${MAKEFLAGS} vmlinux vmlinuz modules
+ make ${MAKEFLAGS} LOCALVERSION= vmlinux vmlinuz modules
else
- make ${MAKEFLAGS} bzImage modules
+ make ${MAKEFLAGS} LOCALVERSION= bzImage modules
fi
}
-package_linux-libre-lts-rt() {
- pkgdesc="The Linux-libre Kernel and modules with full realtime preemption - stable longtime supported kernel package suitable for servers"
+_package() {
+ pkgdesc="The ${pkgbase} kernel and modules with full realtime preemption - stable longtime supported kernel package suitable for servers"
+ [ "${pkgbase}" = "linux-libre" ] && groups=('base')
depends=('coreutils' 'kmod')
optdepends=('crda: to set the correct wireless channels of your country')
- provides=("linux-rt-lts=$pkgver")
- conflicts=('linux-rt-lts')
- replaces=('linux-rt-lts')
- backup=("etc/mkinitcpio.d/${pkgname}.preset")
- install=${pkgname}.install
+ provides=("kernel26${_kernelname}=${pkgver}" "linux${_kernelname}=${pkgver}")
+ conflicts=("kernel26${_kernelname}" "kernel26-libre${_kernelname}" "linux${_kernelname}")
+ replaces=("kernel26${_kernelname}" "kernel26-libre${_kernelname}" "linux${_kernelname}")
+ backup=("etc/mkinitcpio.d/${pkgbase}.preset")
+ install=${pkgbase}.install
if [ "$CARCH" = "mips64el" ]; then
optdepends+=('mkinitcpio: to make the initramfs (needs reinstall of this package)')
conflicts+=('mkinitcpio<0.7')
@@ -175,35 +185,42 @@ package_linux-libre-lts-rt() {
[ $CARCH = "mips64el" ] && KARCH=mips
# get kernel version
- _kernver="$(make kernelrelease)"
+ _kernver="$(make LOCALVERSION= kernelrelease)"
+ _basekernel=${_kernver%%-*}
+ _basekernel=${_basekernel%.*}
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot}
- make INSTALL_MOD_PATH="${pkgdir}" modules_install
+ make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}" modules_install
if [ "$CARCH" == "mips64el" ]; then
- cp vmlinuz "${pkgdir}/boot/vmlinuz-${pkgname}"
- cp vmlinux "${pkgdir}/boot/vmlinux-${pkgname}"
+ cp vmlinuz "${pkgdir}/boot/vmlinuz-${pkgbase}"
+ cp vmlinux "${pkgdir}/boot/vmlinux-${pkgbase}"
else
- cp "arch/${KARCH}/boot/bzImage" "${pkgdir}/boot/vmlinuz-${pkgname}"
+ cp "arch/${KARCH}/boot/bzImage" "${pkgdir}/boot/vmlinuz-${pkgbase}"
fi
# add vmlinux
install -D -m644 vmlinux "${pkgdir}/usr/src/linux-${_kernver}/vmlinux"
# install fallback mkinitcpio.conf file and preset file for kernel
- install -D -m644 "${srcdir}/${pkgname}.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgname}.preset"
+ install -D -m644 "${srcdir}/${pkgbase}.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
# set correct depmod command for install
sed \
- -e "s|ALL_kver=.*|ALL_kver=\"/boot/vmlinuz-${pkgname}\"|g" \
- -e "s|default_image=.*|default_image=\"/boot/initramfs-${pkgname}.img\"|g" \
- -e "s|fallback_image=.*|fallback_image=\"/boot/initramfs-${pkgname}-fallback.img\"|g" \
- -i "${pkgdir}/etc/mkinitcpio.d/${pkgname}.preset"
+ -e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/" \
+ -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/" \
+ -i "${startdir}/${pkgbase}.install"
+ sed \
+ -e "1s|'linux*.*'|'${pkgbase}'|" \
+ -e "s|ALL_kver=.*|ALL_kver=\"/boot/vmlinuz-${pkgbase}\"|" \
+ -e "s|default_image=.*|default_image=\"/boot/initramfs-${pkgbase}.img\"|" \
+ -e "s|fallback_image=.*|fallback_image=\"/boot/initramfs-${pkgbase}-fallback.img\"|" \
+ -i "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
# mkinitcpio 0.7 relies on bzImage to find the kernel version
if [ "$CARCH" == "mips64el" ]; then
- sed -e "s|ALL_kver=.*|ALL_kver=\"${_kernver}\"|g" \
- -i "${pkgdir}/etc/mkinitcpio.d/${pkgname}.preset"
+ sed -e "s|ALL_kver=.*|ALL_kver=\"${_kernver}\"|" \
+ -i "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
fi
# remove build and source links
@@ -225,11 +242,11 @@ package_linux-libre-lts-rt() {
depmod -b "$pkgdir" -F System.map "$_kernver"
}
-package_linux-libre-lts-rt-headers() {
- pkgdesc="Header files and scripts for building modules for linux-libre-lts longtime supported kernel with realtime preemption"
- provides=("linux-rt-lts-headers=${pkgver}")
- conflicts=('linux-rt-lts-headers')
- replaces=('linux-rt-lts-headers')
+_package-headers() {
+ pkgdesc="Header files and scripts for building modules for ${pkgbase} kernel with realtime preemption"
+ provides=("kernel26${_kernelname}-headers=${pkgver}" "linux${_kernelname}-headers=${pkgver}")
+ conflicts=("kernel26${_kernelname}-headers" "kernel26-libre${_kernelname}-headers" "linux${_kernelname}-headers")
+ replaces=("kernel26${_kernelname}-headers" "kernel26-libre${_kernelname}-headers" "linux${_kernelname}-headers")
KARCH=x86
[ $CARCH = "mips64el" ] && KARCH=mips
@@ -237,7 +254,7 @@ package_linux-libre-lts-rt-headers() {
# In case of repackaging this is empty
if [ -z "${_kernver}" ]; then
cd "${srcdir}/linux-${_basekernel}"
- _kernver="$(make kernelrelease)"
+ _kernver="$(make LOCALVERSION= kernelrelease)"
fi
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
@@ -375,3 +392,12 @@ package_linux-libre-lts-rt-headers() {
rm -rf ${pkgdir}/usr/src/linux-${_kernver}/arch/mips
fi
}
+
+pkgname=("${pkgbase}" "${pkgbase}-headers")
+for _p in ${pkgname[@]}; do
+ eval "package_${_p}() {
+ _package${_p#${pkgbase}}
+ }"
+done
+
+# vim:set ts=8 sts=2 sw=2 et: