summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-pae/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-02-04 22:56:21 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-02-04 22:56:21 -0300
commit94fb9fe08abd52c346407e7194e8e54e099988cb (patch)
tree76fafa9dbb83612421531575c9116e849ed2be65 /kernels/linux-libre-pae/PKGBUILD
parentddb2e5d1ce26ebe652f96202b96c514b54faf9fd (diff)
linux-libre-{pae,xen}-4.4.1_gnu-1: updating version
* disable CONFIG_X86_VERBOSE_BOOTUP - FS#47402 -> https://bugs.archlinux.org/task/47402 * enable CONFIG_VGACON_SOFT_SCROLLBACK - FS#47442 -> https://bugs.archlinux.org/task/47442 * unsetting CONFIG_ACPI_REV_OVERRIDE_POSSIBLE - FS#47710 -> https://bugs.archlinux.org/task/47710 * fix sdhci broken on some boards - FS#47778 -> https://bugs.archlinux.org/task/47778 * fix kernel panics on platform modules - FS#47805 -> https://bugs.archlinux.org/task/47805 * fix debug output - FS#47849 -> https://bugs.archlinux.org/task/47849 * fix FS#47757 -> https://bugs.archlinux.org/task/47757
Diffstat (limited to 'kernels/linux-libre-pae/PKGBUILD')
-rw-r--r--kernels/linux-libre-pae/PKGBUILD42
1 files changed, 31 insertions, 11 deletions
diff --git a/kernels/linux-libre-pae/PKGBUILD b/kernels/linux-libre-pae/PKGBUILD
index e9c72415a..435dbea65 100644
--- a/kernels/linux-libre-pae/PKGBUILD
+++ b/kernels/linux-libre-pae/PKGBUILD
@@ -8,8 +8,8 @@
# Based on linux-pae package
pkgbase=linux-libre-pae
-_pkgbasever=4.3-gnu
-_pkgver=4.3.4-gnu
+_pkgbasever=4.4-gnu
+_pkgver=4.4.1-gnu
_replacesarchkernel=('linux%') # '%' gets replaced with _kernelname
_replacesoldkernels=() # '%' gets replaced with _kernelname
@@ -39,12 +39,15 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch'
- '0001-disabling-primary-plane-in-the-noatomic-case.patch'
+ 'tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch'
+ '0001-sdhci-revert.patch'
+ '0001-4.4-revert-btrfs.patch'
+ '0001-4.4-revert-xfs.patch'
'0001-drm-radeon-Make-the-driver-load-without-the-firmwares.patch'
'0002-usb-serial-gadget-no-TTY-hangup-on-USB-disconnect-WI.patch')
-sha256sums=('1d280ae2730eb6c9b8c7e920cac2e8111c8db02c498db0c142860a84106cc169'
+sha256sums=('f53e99866c751f21412737d1f06b0721e207f495c8c64f97dffb681795ee69a0'
'SKIP'
- '73ad579342bf4d4954953fa76a79454d81213a151694a7ac70d486808f1bdf3a'
+ 'ed09b329d879bb758374b6a76acb841cdf63a6638720378657fb2b6eeed6b265'
'SKIP'
'bfd4a7f61febe63c880534dcb7c31c5b932dde6acf991810b41a939a93535494'
'SKIP'
@@ -52,10 +55,13 @@ sha256sums=('1d280ae2730eb6c9b8c7e920cac2e8111c8db02c498db0c142860a84106cc169'
'SKIP'
'6de8a8319271809ffdb072b68d53d155eef12438e6d04ff06a5a4db82c34fa8a'
'SKIP'
- '147161191a8247c606abc8f0d2a5322ab94b5c69d9f2d89825209256d7935a6e'
+ '90ba70b4e20721f1f0c718f8a2c3b4904e20c81b4ade9652f94be69d541f04cc'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- 'abdd04bd6beecb7c961130a68d71e6332bd260462eeaa2f4f8e634de813dcc4d'
+ 'ab57037ecee0a425c612babdff47c831378bca0bff063a1308599989a350226d'
+ '5313df7cb5b4d005422bd4cd0dae956b2dadba8f3db904275aaf99ac53894375'
+ '51586b733e9f178bebe577258b6057b035eded516ffe8bf8bbb26cb0b26c4958'
+ 'ffbfaa192d17bfc7c6293aa9a07efe57f65177051ae3d8033d5e45a7bca2e0ad'
'61370b766e0c60b407c29d2c44b3f55fc352e9049c448bc8fcddb0efc53e42fc'
'3d3266bd082321dccf429cc2200d1a4d870d2031546f9f591b6dfbb698294808')
validpgpkeys=(
@@ -83,15 +89,24 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+ # revert http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9faac7b95ea4f9e83b7a914084cc81ef1632fd91
+ # fixes #47778 sdhci broken on some boards
+ # https://bugzilla.kernel.org/show_bug.cgi?id=106541
+ patch -Rp1 -i "${srcdir}/0001-sdhci-revert.patch"
+
+ # fixes #47805 kernel panics on platform modules
+ # https://bugzilla.kernel.org/show_bug.cgi?id=110751
+ patch -Np1 -i "${srcdir}/tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch"
+
+ # #47757 fix broken suspend from btrfs and xfs
+ patch -Np1 -i "${srcdir}/0001-4.4-revert-xfs.patch"
+ patch -Np1 -i "${srcdir}/0001-4.4-revert-btrfs.patch"
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
- # fix #46968
- # hangs on older intel hardware
- patch -Np1 -i "${srcdir}/0001-disabling-primary-plane-in-the-noatomic-case.patch"
-
# make the radeon driver load without the firmwares
# http://www.fsfla.org/pipermail/linux-libre/2015-August/003098.html
patch -p1 -i "${srcdir}/0001-drm-radeon-Make-the-driver-load-without-the-firmwares.patch"
@@ -309,6 +324,11 @@ _package-headers() {
# remove unneeded architectures
find "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch -mindepth 1 -maxdepth 1 -type d -not -name "$KARCH" -exec rm -rf {} +
+
+ # remove a files already in docs package
+ rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild/Kconfig.recursion-issue-01"
+ rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild/Kconfig.recursion-issue-02"
+ rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild/Kconfig.select-break"
}
_package-docs() {