summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-pae/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-23 05:56:12 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-23 05:56:12 -0300
commite015c3d8bae751dc9788da5604cfece47d2c4ce8 (patch)
tree3d433cb02a2b0393d5a430ddb7468e8f9b90d3e0 /kernels/linux-libre-pae/PKGBUILD
parent28529fefc594bf968ca30905a5a2d6c9ae1d6f3c (diff)
fix some issues on the kernels
Diffstat (limited to 'kernels/linux-libre-pae/PKGBUILD')
-rw-r--r--kernels/linux-libre-pae/PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/kernels/linux-libre-pae/PKGBUILD b/kernels/linux-libre-pae/PKGBUILD
index ec7336a48..a984d646c 100644
--- a/kernels/linux-libre-pae/PKGBUILD
+++ b/kernels/linux-libre-pae/PKGBUILD
@@ -10,8 +10,9 @@
pkgbase=linux-libre-pae # Build stock -pae kernel
_pkgbasever=3.16-gnu
_pkgver=3.16.1-gnu
+_archver=3.16.1
-_replaces=('kernel26%' 'kernel26-libre%' 'linux%' 'linux-libre%-kmod-alx') # '%' gets replaced with _kernelname
+_replaces=('kernel26%' 'linux%') # '%' gets replaced with _kernelname
_srcname=linux-${_pkgbasever%-*}
pkgver=${_pkgver//-/.}
@@ -21,8 +22,8 @@ url="http://linux-libre.fsfla.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
-source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasekernel}/linux-libre-${_pkgbasekernel}.tar.xz"
- "http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgver}/patch-${_pkgbasekernel}-${_pkgver}.xz"
+source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/linux-libre-${_pkgbasever}.tar.xz"
+ "http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgver}/patch-${_pkgbasever}-${_pkgver}.xz"
# the main kernel config files
'config'
# standard config files for mkinitcpio ramdisk
@@ -100,7 +101,7 @@ _package() {
[ "${pkgbase}" = "linux-libre" ] && groups=('base')
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')
- provides=( "${_replaces[@]/%/=${pkgver}}")
+ provides=( "${_replaces[@]/%/=${_archver}}")
conflicts=("${_replaces[@]}")
replaces=( "${_replaces[@]}")
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
@@ -161,7 +162,7 @@ _package() {
_package-headers() {
pkgdesc="Header files and scripts for building modules for ${pkgbase^} kernel"
- provides=( "${_replaces[@]/%/-headers=${pkgver}}")
+ provides=( "${_replaces[@]/%/-headers=${_archver}}")
conflicts=("${_replaces[@]/%/-headers}")
replaces=( "${_replaces[@]/%/-headers}")
@@ -280,11 +281,11 @@ _package-headers() {
_package-docs() {
pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase^} kernel"
- provides=("kernel26${_kernelname}-docs=${pkgver}" "linux${_kernelname}-docs=${pkgver}")
- conflicts=("kernel26${_kernelname}-docs" "kernel26-libre${_kernelname}-docs" "linux${_kernelname}-docs")
- replaces=("kernel26${_kernelname}-docs" "kernel26-libre${_kernelname}-docs" "linux${_kernelname}-docs")
+ provides=( "${_replaces[@]/%/-docs=${_archver}}")
+ conflicts=("${_replaces[@]/%/-docs}")
+ replaces=( "${_replaces[@]/%/-docs}")
- cd "${srcdir}/linux-${_basekernel}"
+ cd "${srcdir}/${_srcname}"
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build"
cp -al Documentation "${pkgdir}/usr/lib/modules/${_kernver}/build"