summaryrefslogtreecommitdiff
path: root/libre-testing/icecat/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-07-23 20:20:54 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-07-23 20:20:54 -0300
commit63a3416c08d13ca99525874a5b4fb528ce5ad468 (patch)
treec99a4198911378a50d3e6c28817da853a5c36b15 /libre-testing/icecat/PKGBUILD
parent315a1a39be2506ce7c7df9651df75dc563e1dcfb (diff)
icecat-31.8.0_gnu1-2: move revision to [libre], build icecat without system libraries from now onwards to prevent segfault
Diffstat (limited to 'libre-testing/icecat/PKGBUILD')
-rw-r--r--libre-testing/icecat/PKGBUILD229
1 files changed, 0 insertions, 229 deletions
diff --git a/libre-testing/icecat/PKGBUILD b/libre-testing/icecat/PKGBUILD
deleted file mode 100644
index ea7aa6e96..000000000
--- a/libre-testing/icecat/PKGBUILD
+++ /dev/null
@@ -1,229 +0,0 @@
-# Maintainer: André Silva <emulatorman@parabola.nu>
-# Contributor: Márcio Silva <coadde@parabola.nu>
-# Contributor (ConnochaetOS): Henry Jensen <hjensen@connochaetos.org>
-# Contributor: Luke Shumaker <lukeshu@sbcglobal.net>
-# Contributor: fauno <fauno@kiwwwi.com.ar>
-# Contributor: vando <facundo@esdebian.org>
-# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
-# Contributor: Figue <ffigue at gmail>
-# Thank you very much to the older contributors:
-# Contributor: evr <evanroman at gmail>
-# Contributor: Muhammad 'MJ' Jassim <UnbreakableMJ@gmail.com>
-
-_pgo=true
-
-pkgname=icecat
-_pkgver=31.8.0-gnu1
-pkgver=${_pkgver//-/_}
-pkgrel=2
-
-pkgdesc="GNU IceCat, the standalone web browser based on Mozilla Firefox."
-arch=(i686 x86_64 mips64el)
-license=(MPL GPL LGPL)
-depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hicolor-icon-theme hunspell icu=55.1 libevent libvpx=1.4.0 libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification)
-makedepends=(diffutils gst-plugins-base-libs imake inetutils libpulse mesa python2 unzip yasm zip)
-options=(!emptydirs !makeflags debug)
-if $_pgo; then
- makedepends+=(xorg-server-xvfb)
- options+=(!ccache)
-fi
-optdepends=('networkmanager: Location detection via available WiFi networks'
- 'gst-plugins-good: h.264 video'
- 'gst-libav: h.264 video')
-url="http://www.gnu.org/software/gnuzilla/"
-install=$pkgname.install
-source=(http://ftp.gnu.org/gnu/gnuzilla/${_pkgver%-*}/$pkgname-$_pkgver.tar.bz2{,.sig}
- mozconfig
- mozconfig.pgo
- libre.patch
- gnu_headshadow.png
- $pkgname.desktop
- $pkgname-install-dir.patch
- freetype26.patch
- vendor.js
- rhbz-966424.patch
- $pkgname-fixed-loading-icon.png
- fixing_nullptr_31.7.0.patch)
-sha256sums=('370087d0adadf8b1c1e6a9920e26488a8902b9dc461d305f258fddb26a129d87'
- 'SKIP'
- '98e5128ee418a60a98f77270f939b2c5b9c62ba93ab65676dd17c4a16290f027'
- '92d7ea9feb8d2814d1abaf5cf4012983a2fb9cc56b26a5d7c7c3898aedf06fb4'
- '8082a8a5adf21c50fa77650c74adcd6fedbf7bedcdb6b8ae29529ca96adeb05d'
- '93e3001ce152e1d142619e215a9ef07dd429943b99d21726c25da9ceb31e31cd'
- '52df9ffeb52166ed4abd9a132ee4a9017b9c4980f0725ba383610ccfb06d4745'
- '5bdab2de5520fb4d3dbc453d9f73d20e0e077bf652bc780fc17184ba6c718a47'
- 'b9c440406644fde5097da8717f0b5e5e973d11ec4dd6d4a0570ca7094d96dc85'
- '977aa49b940f1da049cefa2878a63ac6669a78e63e9d55bb11db7b8f8fb64c33'
- 'd25c6e95d20ec622a51346897d986fdd97074023d6a02bee0533773a195f8233'
- '68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
- 'd57d0e4d5bc66323388e8f3c9999ed443abfd304a28a1696cc6f4518ed0d0f2a')
-validpgpkeys=('A57369A8BABC2542B5A0368C3C76EED7D7E04784') # Ruben Rodriguez
-
-prepare() {
- export GNU_BUILD="gnuzilla-release"
-
- mv $pkgname-${pkgver%_*} "$srcdir/$GNU_BUILD"
- cd "$srcdir/$GNU_BUILD"
-
- # Put gnu_headshadow.png on the source code
- install -m644 "$srcdir/gnu_headshadow.png" \
- browser/base/content/abouthome
-
- # Install to /usr/lib/$pkgname
- patch -Np1 -i "$srcdir/$pkgname-install-dir.patch"
-
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1143411
- patch -Np1 -i "$srcdir/freetype26.patch"
-
- # https://bugs.archlinux.org/task/41689
- patch -Np1 -i "$srcdir/rhbz-966424.patch"
-
- # Patch for GCC 5.1
- patch -Np1 -i "$srcdir/fixing_nullptr_31.7.0.patch"
-
- # Patch and remove anything that's left
- patch -Np1 -i "$srcdir/libre.patch"
- sed -i '\|return| s|Flash|SWF Player|g;
- ' browser/base/content/pageinfo/permissions.js \
- browser/base/content/browser-plugins.js
- sed -i '\|["]displayName["][:] ["]Flash["]| s|Flash|SWF Player|
- \|["]displayName["][:] ["]Shockwave["]| s|Shockwave|DCR Player|
- \|["]displayName["][:] ["]QuickTime["]| s|QuickTime|MOV Player|
- \|installLinux| s|true|false|
- ' browser/base/content/browser-plugins.js
- rm -v browser/base/content/abouthome/snippet*.png || true
- sed -i '\|abouthome/snippet|d
- ' browser/base/jar.mn
-
- # Replace common URLs
- sed -i '\|extensions[.]getAddons[.]get[.]url| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
- \|extensions[.]getAddons[.]search[.]browseURL| s|https://addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
- \|extensions[.]getAddons[.]search[.]url| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
- \|extensions[.]getAddons[.]search[.]url| s|https://directory[.]fsf[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
- \|extensions[.]webservice[.]discoverURL| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
- \|extensions[.]webservice[.]discoverURL| s|https://directory[.]fsf[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
- \|browser[.]search[.]searchEnginesURL| s|https://addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
- \|browser[.]search[.]searchEnginesURL| s|https://mycroft[.]mozdev[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
- \|plugins[.]update[.]url| s|https://www[.]mozilla[.]org/[%]LOCALE[%]/plugincheck/["][)][;]|https://trisquel.info/en/browser");|g;
- \|plugins[.]update[.]url| s|https://www[.]gnu[.]org/software/gnuzilla/["][)][;]|https://trisquel.info/en/browser");|g;
- ' browser/app/profile/icecat.js
-
- # Load our build config, disable SafeSearch
- cp "$srcdir/mozconfig" .mozconfig
-
- if $_pgo; then
- cat "$srcdir/mozconfig.pgo" >> .mozconfig
- fi
-
- # From js on abslibre-mips64el.git
- if [ "$CARCH" = "mips64el" ]; then
- msg "Force disabling JIT."
- sed -ri 's/#define ENABLE_(JIT|ASSEMBLER) 1/#define ENABLE_\1 0/' \
- js/src/assembler/wtf/Platform.h
- sed -ri 's/ENABLE_(JIT|ASSEMBLER)=1/ENABLE_\1=0/' js/src/Makefile.{in,ref}
-
- echo "ac_add_options --disable-methodjit" >> .mozconfig
- echo "ac_add_options --disable-tracejit" >> .mozconfig
- fi
-
- # This is a bug, we should fix it
- if [ "$CARCH" = "mips64el" ]; then
- # Fix MIPS N32 support.
- sed -i 's/defined(_ABIO32)/(defined(_ABIO32) || defined(_ABIN32))/' \
- js/src/assembler/wtf/Platform.h
- # Disable JIT.
- sed -ri 's/#define ENABLE_(JIT|ASSEMBLER) 1/#define ENABLE_\1 0/' \
- js/src/assembler/wtf/Platform.h
- sed -ri 's/ENABLE_(JIT|ASSEMBLER)=1/ENABLE_\1=0/' js/src/Makefile.in
- echo 'ac_add_options --disable-methodjit' >> .mozconfig
- echo 'ac_add_options --disable-tracejit' >> .mozconfig
- echo 'ac_add_options --disable-jemalloc' >> .mozconfig
- fi
-
- # Fixing for libvpx >= 1.4.0
- sed -i 's|IMG_FMT_I420|VPX_IMG_FMT_I420|;
- s|PLANE_U|VPX_PLANE_U|;
- s|PLANE_V|VPX_PLANE_V|;
- s|PLANE_Y|VPX_PLANE_Y|;
- s|VPX_VPX_PLANE_|VPX_PLANE_|;
- ' content/media/encoder/VP8TrackEncoder.cpp \
- media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc
-
- mkdir "$srcdir/path"
-
- # WebRTC build tries to execute "python" and expects Python 2
- ln -s /usr/bin/python2 "$srcdir/path/python"
-
- # configure script misdetects the preprocessor without an optimization level
- # https://bugs.archlinux.org/task/34644
- sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' configure
-
- # Fix tab loading icon (flickers with libpng 1.6)
- # https://bugzilla.mozilla.org/show_bug.cgi?id=841734
- # TODO: Remove this; IceCat 36 might use CSS animations for the loading icon
- # https://bugzilla.mozilla.org/show_bug.cgi?id=759252
- cp "$srcdir/$pkgname-fixed-loading-icon.png" \
- browser/themes/linux/tabbrowser/loading.png
-
- # Remove non-existent file on Makefile.in
- sed -i '\|build/pgo/blueprint/valid.png|d' build/Makefile.in
-}
-
-build() {
- export GNU_BUILD="gnuzilla-release"
-
- cd "$srcdir/$GNU_BUILD"
-
- export PATH="$srcdir/path:$PATH"
- export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$pkgname"
- export PYTHON="/usr/bin/python2"
-
- if $_pgo; then
- # Do PGO
- xvfb-run -a -s "-extension GLX -screen 0 1280x1024x24" \
- make -f client.mk build MOZ_PGO=1
- else
- make -f client.mk build
- fi
-}
-
-package() {
- export GNU_BUILD="gnuzilla-release"
-
- cd "$srcdir/$GNU_BUILD"
- make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
-
- install -Dm644 ../vendor.js "$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
-
-
- brandingdir=browser/branding/official
- icondir="$pkgdir/usr/share/icons/hicolor"
- for i in 16x16 32x32 48x48; do
- install -Dm644 "$brandingdir/default${i/x*/}.png" "$icondir/$i/apps/$pkgname.png"
- done
- install -Dm644 "$brandingdir/content/icon64.png" \
- "$icondir/64x64/apps/$pkgname.png"
- install -Dm644 "$brandingdir/mozicon128.png" \
- "$icondir/128x128/apps/$pkgname.png"
- install -Dm644 "$brandingdir/content/about-logo.png" \
- "$icondir/192x192/apps/$pkgname.png"
- install -Dm644 "$brandingdir/content/about-logo@2x.png" \
- "$icondir/384x384/apps/$pkgname.png"
-
- install -d "$pkgdir/usr/share/applications"
- install -m644 "$srcdir/$pkgname.desktop" \
- "$pkgdir/usr/share/applications"
-
- # Use system-provided dictionaries
- rm -rf "$pkgdir/usr/lib/$pkgname/"{dictionaries,hyphenation}
- ln -s /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
- ln -s /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
-
- rm -rf "$pkgdir/usr/lib/$pkgname/browser/"{searchplugins,plugins}
- ln -sf /usr/lib/mozilla/plugins "$pkgdir/usr/lib/$pkgname/browser/plugins"
- ln -sf /usr/lib/mozilla/searchplugins "$pkgdir/usr/lib/$pkgname/browser/searchplugins"
-
- # Workaround for now:
- #https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -sf $pkgname "$pkgdir/usr/lib/$pkgname/$pkgname-bin"
-}