summaryrefslogtreecommitdiff
path: root/libre-testing/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-25 08:17:24 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-25 08:17:24 -0300
commit022dc975f33882a2a653bc5e30e0a88bfc5afd66 (patch)
treea6a89245d7010c934f5bda564a3f91e72ac3f6ce /libre-testing/linux-libre/PKGBUILD
parentd46a4c30f490b87f860b0c0f8d6c8a9d27165734 (diff)
linux-libre: fix Atmel maXTouch touchscreen support -> https://labs.parabola.nu/issues/877
Diffstat (limited to 'libre-testing/linux-libre/PKGBUILD')
-rw-r--r--libre-testing/linux-libre/PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/libre-testing/linux-libre/PKGBUILD b/libre-testing/linux-libre/PKGBUILD
index 6b6feb0c8..1c51349e5 100644
--- a/libre-testing/linux-libre/PKGBUILD
+++ b/libre-testing/linux-libre/PKGBUILD
@@ -47,6 +47,7 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
'change-default-console-loglevel.patch'
'0001-drm-radeon-Make-the-driver-load-without-the-firmwares.patch'
'0002-usb-serial-gadget-no-TTY-hangup-on-USB-disconnect-WI.patch'
+ '0003-fix-atmel-maxtouch-touchscreen-support.patch'
# armv7h patches
"https://repo.parabola.nu/other/rcn-libre/patches/${_pkgver%-*}/rcn-libre-${_pkgver%-*}-${rcnrel}.patch"
"https://repo.parabola.nu/other/rcn-libre/patches/${_pkgver%-*}/rcn-libre-${_pkgver%-*}-${rcnrel}.patch.sig"
@@ -73,6 +74,7 @@ sha256sums=('c37a135518d5a69b26bae8441bc20e5a5ea87d3228cfe72f75a714cff730a84e'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'93edfa289033e491ba7f9d6886943ce68c94fb45dc6817a3fc577c7ba6c369d6'
'3d3266bd082321dccf429cc2200d1a4d870d2031546f9f591b6dfbb698294808'
+ '0a6f76bbc03ae6e846a4ba4e31bbc0a40b1ae538c1271defcbe3089e00a4b53d'
'9865a47b50ccab0993f9b371f45b526162307fffc67dfadcae6fae31d05a67b9'
'SKIP'
'abc20251d9becc566e46ff0fca77074eca9de5d119d2dbccb7d9c933b2d59979'
@@ -144,6 +146,11 @@ prepare() {
# http://www.coreboot.org/EHCI_Gadget_Debug
patch -p1 -i "${srcdir}/0002-usb-serial-gadget-no-TTY-hangup-on-USB-disconnect-WI.patch"
+ # fix Atmel maXTouch touchscreen support
+ # https://labs.parabola.nu/issues/877
+ # http://www.fsfla.org/pipermail/linux-libre/2015-November/003202.html
+ patch -p1 -i "${srcdir}/0003-fix-atmel-maxtouch-touchscreen-support.patch"
+
cat "${srcdir}/config.${CARCH}" > ./.config
# append pkgrel to extraversion