summaryrefslogtreecommitdiff
path: root/libre-testing/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-04 01:10:04 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-04 01:10:04 -0300
commit64117aae0f7248f9c1cd43ef4eb2ef5790924f06 (patch)
tree3d656c3d42aacf6a230e8ac95b3a3a24a000f827 /libre-testing/linux-libre/PKGBUILD
parentfdf42797fdbf90d5913c730458d5484a9b440382 (diff)
linux-libre-3.14-3: updating revision
* enable CONFIG_INFINIBAND_IPOIB_CM (FS#39701 => https://bugs.archlinux.org/task/39701) * disable X86_SYSFB and FB_SIMPLE (FS#39715 => https://bugs.archlinux.org/task/39715) * fix FSID of rootfs being 0 For st_dev in struct stat, the value 0 is an error. Make sure rootfs has value 1. This fixes the coreutils cp -ax issue (although that code has already been improved in coreutils, too) and somewhat fixes the switch_root problem in util-linux. It is still possible that rootfs gets an FSID >1 in future versions, so util-linux still needs to be fixed. This is unrelated to the mount id issue in /proc/*/mountinfo - the mount id may still be zero. * revert a patch that always enables autosuspend on intel bluetoothh xhci still sucks and breaks this. I am reverting this commit for reasons that are in no way selfish.
Diffstat (limited to 'libre-testing/linux-libre/PKGBUILD')
-rw-r--r--libre-testing/linux-libre/PKGBUILD29
1 files changed, 21 insertions, 8 deletions
diff --git a/libre-testing/linux-libre/PKGBUILD b/libre-testing/linux-libre/PKGBUILD
index aad86c37c..88557d441 100644
--- a/libre-testing/linux-libre/PKGBUILD
+++ b/libre-testing/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 209725 2014-04-01 20:53:27Z thomas $
+# $Id: PKGBUILD 209774 2014-04-03 22:57:31Z thomas $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -13,7 +13,7 @@ _basekernel=3.14
#_sublevel=7
#pkgver=${_basekernel}.${_sublevel}
pkgver=${_basekernel}
-pkgrel=1
+pkgrel=3
_lxopkgver=${_basekernel}.0 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
@@ -34,19 +34,23 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'0002-module-allow-multiple-calls-to-MODULE_DEVICE_TABLE-p.patch'
'0003-module-remove-MODULE_GENERIC_TABLE.patch'
'0004-Revert-syscalls.h-use-gcc-alias-instead-of-assembler.patch'
+ '0005-fs-Don-t-return-0-from-get_anon_bdev.patch'
+ '0006-Revert-Bluetooth-Enable-autosuspend-for-Intel-Blueto.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.xz")
sha256sums=('477555c709b9407fe37dbd70d3331ff9dde1f9d874aba2741f138d07ae6f281b'
- '052ef80fb78921228fcf9fa1e8b564398864f9aafda1563e66997b4fae178c62'
- '9e33e481d5c104a9c7e3d0d4cd4399467b7974cbe656a088a2e38a610f2be583'
+ 'a5211049b129aa257a05a611fd800969518368329a0e198249e7873ca3c4ae33'
+ '5a54bad7c3d660f62162227351303341b944a8290f3cd8403481822b34d73f88'
'dfe01c93d83cdac9ca502715ceb6ac9502d327c939fec2e3052a5a58422dc176'
'c5451d5e1eafc4f8d28b1a2958ec3102c124433a414a86450fc32058e004156b'
'55bf07738a3286168a7929ae16dbca29defd14e77b9d24c487ae4c3d12bb9eb9'
'8303b426b1a6dce456b2350003558ae312d21cab0ae6c1f0d7b9d21395f4e177'
'faced4eb4c47c4eb1a9ee8a5bf8a7c4b49d6b4d78efbe426e410730e6267d182'
- '29a958c37e1fb04c49b1cc3be4f38b53ffdeef61ab049865209f6b77817302d0'
- 'd8db3b235d871d2b27986d3cb73a57b1d33fed52196a4b608152498a57e93838'
- 'eb9a773b7b978bc508e8459ef835ff2cb8a41bb235caff1c18c5b718d7ce902c'
- '4edd92642d710d8a351dd2acce36d412eccbf60380f9d0368ec315acb49ad704'
+ 'ad22f6e1a2869730828ddaf93da8b8a748421b7afdd34e1213566985fe7b01dd'
+ '29e612a8dda2b2b8af116c16b546a0e1d159f249bfd9628d640cad0f61f0cc4f'
+ '555133445de48e781ced3a450bcdf9bfbe4d66b118bbd5b28fea789fa023dd66'
+ 'dc1eca93dad93c9c015332d188f5a69508c2077536b8be653d2ff45f1b034941'
+ '1f572e748d96403218e846ec469474f557f04d2f5ff137dd2a31fffa193f760e'
+ 'a413700adf3b45b7d3c18d2ffed390b9e5769cb361a9a0530f98bfff29fd0aef'
'16625d5e688626de0e508b70b42b11777bb30c7903671d970d8a5cfefa32e693')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
@@ -86,6 +90,15 @@ prepare() {
# For details, see https://lkml.org/lkml/2014/1/26/22
patch -p1 -i "${srcdir}/0004-Revert-syscalls.h-use-gcc-alias-instead-of-assembler.patch"
+ # Fix various bugs caused by rootfs having FSID 0
+ # See http://www.spinics.net/lists/kernel/msg1716924.html
+ patch -p1 -i "${srcdir}/0005-fs-Don-t-return-0-from-get_anon_bdev.patch"
+
+ # Disable usb autosuspend for intel btusb
+ # See http://www.spinics.net/lists/kernel/msg1716461.html
+ # Until a solution is found, make sure the driver leaves autosuspend alone
+ patch -p1 -i "${srcdir}/0006-Revert-Bluetooth-Enable-autosuspend-for-Intel-Blueto.patch"
+
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \