summaryrefslogtreecommitdiff
path: root/libre-testing/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-02-07 22:44:25 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-02-07 22:44:25 -0200
commite2a3bd26573b1e03dc730aa0b89ae9ef70c47b5a (patch)
tree47eadcacb2f2a965db319a38b380087a933e3b4c /libre-testing/linux-libre/PKGBUILD
parentcd33b4d3fb678ab356ae86e49212fd3b0c1f7f3d (diff)
linux-libre-3.13.2-1: updating version
Diffstat (limited to 'libre-testing/linux-libre/PKGBUILD')
-rw-r--r--libre-testing/linux-libre/PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/libre-testing/linux-libre/PKGBUILD b/libre-testing/linux-libre/PKGBUILD
index c9368029f..27a13b53a 100644
--- a/libre-testing/linux-libre/PKGBUILD
+++ b/libre-testing/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 204858 2014-01-29 14:54:08Z tpowa $
+# $Id: PKGBUILD 205546 2014-02-06 22:45:04Z thomas $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -10,9 +10,9 @@
pkgbase=linux-libre # Build stock -LIBRE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.13
-_sublevel=1
+_sublevel=2
pkgver=${_basekernel}.${_sublevel}
-pkgrel=2
+pkgrel=1
_lxopkgver=${_basekernel}.1 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
@@ -38,10 +38,9 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'0006-rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-no.patch'
'0001-syscalls.h-use-gcc-alias-instead-of-assembler-aliase.patch'
'i8042-fix-aliases.patch'
- '0001-x86-x32-Correct-invalid-use-of-user-timespec-in-the-.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.xz")
md5sums=('98a8e803e0ed08557f3cdd4d56b0ddc1'
- '312e6bf90c4de3f455669f8cccf4eddd'
+ '5594978ab8b62033274cf36305baf238'
'b6a3a3f9cac1be38384241ad58d45d46'
'3740951ae165b89a2139d45ae7d82173'
'e49ac236dfeef709f91a3d993ea7b62c'
@@ -58,7 +57,6 @@ md5sums=('98a8e803e0ed08557f3cdd4d56b0ddc1'
'a724515b350b29c53f20e631c6cf9a14'
'e6fa278c092ad83780e2dd0568e24ca6'
'93dbf73af819b77f03453a9c6de2bb47'
- '336d2c4afd7ee5f2bdf0dcb1a54df4b2'
'7710668dfdd138f3ad0b93c50455455e')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
@@ -112,9 +110,6 @@ prepare() {
# Fix i8042 aliases
patch -p1 -i "${srcdir}/i8042-fix-aliases.patch"
- # Fix CVE-2014-0038
- patch -p1 -i "${srcdir}/0001-x86-x32-Correct-invalid-use-of-user-timespec-in-the-.patch"
-
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \