summaryrefslogtreecommitdiff
path: root/libre-testing/uboot4extlinux-omap3_beagle/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-02 00:23:43 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-02 00:28:07 -0300
commit11467233d8b439275ce1e1db650a4c6f91a9db1f (patch)
tree62cc14ffe05dcc5541210d2073a4c119e6a125c2 /libre-testing/uboot4extlinux-omap3_beagle/PKGBUILD
parenta44772df880c7bcf6ba114a6e4d86ba4ff6b4adc (diff)
move uboot4extlinux packages to [libre-testing] since it aren't stable yet
Diffstat (limited to 'libre-testing/uboot4extlinux-omap3_beagle/PKGBUILD')
-rw-r--r--libre-testing/uboot4extlinux-omap3_beagle/PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/libre-testing/uboot4extlinux-omap3_beagle/PKGBUILD b/libre-testing/uboot4extlinux-omap3_beagle/PKGBUILD
new file mode 100644
index 000000000..c3d833ad8
--- /dev/null
+++ b/libre-testing/uboot4extlinux-omap3_beagle/PKGBUILD
@@ -0,0 +1,46 @@
+# U-Boot: BeagleBoard and BeagleBoard-xM
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+buildarch=4
+
+pkgname=uboot4extlinux-omap3_beagle
+pkgver=2016.01
+pkgrel=2
+pkgdesc="U-Boot with Extlinux support for BeagleBoard and BeagleBoard-xM"
+arch=('armv7h')
+url="http://git.denx.de/u-boot.git/"
+license=('GPL')
+conflicts=('uboot-omap3_beagle' 'uboot4grub-omap3_beagle')
+makedepends=('bc')
+backup=(boot/extlinux/extlinux.conf)
+install=${pkgname}.install
+source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
+ '0001-parabola-arm-modifications.patch'
+ 'extlinux.conf'
+ 'uEnv.txt')
+md5sums=('7d4f65fd43d4d706f5c5650e020d899d'
+ 'da3d52f785bce02602f88fb85f74de2f'
+ '5172c86fd491728aad8109ebb8a997f8'
+ 'd41d8cd98f00b204e9800998ecf8427e')
+
+prepare() {
+ cd u-boot-${pkgver}
+ patch -Np1 -i ../0001-parabola-arm-modifications.patch
+}
+
+build() {
+ cd u-boot-${pkgver}
+
+ unset LDFLAGS CFLAGS CXXFLAGS
+
+ make distclean
+ make omap3_beagle_config
+ make
+}
+
+package() {
+ cd u-boot-${pkgver}
+ mkdir -p "${pkgdir}"/boot/extlinux
+ cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}"/boot
+ cp "${srcdir}"/extlinux.conf "${pkgdir}"/boot/extlinux
+}