summaryrefslogtreecommitdiff
path: root/libre-testing/uboot4extlinux-omap4_panda/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-02 00:23:43 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-02 00:28:07 -0300
commit11467233d8b439275ce1e1db650a4c6f91a9db1f (patch)
tree62cc14ffe05dcc5541210d2073a4c119e6a125c2 /libre-testing/uboot4extlinux-omap4_panda/PKGBUILD
parenta44772df880c7bcf6ba114a6e4d86ba4ff6b4adc (diff)
move uboot4extlinux packages to [libre-testing] since it aren't stable yet
Diffstat (limited to 'libre-testing/uboot4extlinux-omap4_panda/PKGBUILD')
-rw-r--r--libre-testing/uboot4extlinux-omap4_panda/PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/libre-testing/uboot4extlinux-omap4_panda/PKGBUILD b/libre-testing/uboot4extlinux-omap4_panda/PKGBUILD
new file mode 100644
index 000000000..6cb84e451
--- /dev/null
+++ b/libre-testing/uboot4extlinux-omap4_panda/PKGBUILD
@@ -0,0 +1,48 @@
+# U-Boot: PandaBoard and PandaBoard ES
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+buildarch=4
+
+pkgname=uboot4extlinux-omap4_panda
+pkgver=2016.01
+pkgrel=2
+pkgdesc="U-Boot with Extlinux support for PandaBoard and PandaBoard ES"
+arch=('armv7h')
+url="http://git.denx.de/u-boot.git/"
+conflicts=('uboot-omap4_panda' 'uboot4grub-omap4_panda')
+makedepends=('bc')
+license=('GPL')
+install=${pkgname}.install
+backup=('boot/extlinux/extlinux.conf' 'boot/uEnv.txt')
+source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
+ '0001-parabola-arm-modifications.patch'
+ 'extlinux.conf'
+ 'uEnv.txt')
+md5sums=('7d4f65fd43d4d706f5c5650e020d899d'
+ 'b74e858feeed48acaba5ac0548d675ca'
+ '12c61073bb860f4c8d8ec59145c267ed'
+ '86004660f2912861a040e335c9c0e85b')
+
+prepare() {
+ cd u-boot-${pkgver}
+
+ patch -Np1 -i ../0001-parabola-arm-modifications.patch
+}
+
+build() {
+ cd u-boot-${pkgver}
+
+ unset LDFLAGS
+
+ make distclean
+ make omap4_panda_config
+ make
+}
+
+package() {
+ cd u-boot-${pkgver}
+
+ mkdir -p "${pkgdir}"/boot/extlinux
+ cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}"/boot
+ cp "${srcdir}"/extlinux.conf "${pkgdir}"/boot/extlinux
+}