summaryrefslogtreecommitdiff
path: root/libre/abiword-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-01-12 06:34:02 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-01-12 06:34:02 -0200
commit1291ce91faee749ec2a855c946161976ee616086 (patch)
treec91992084cad677bb28fc59a513a32b5b49eaf42 /libre/abiword-libre/PKGBUILD
parent9e33e16c2e12009cca2cdec1e03e80dd7f275b11 (diff)
abiword-libre: add mksource
Diffstat (limited to 'libre/abiword-libre/PKGBUILD')
-rw-r--r--libre/abiword-libre/PKGBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/libre/abiword-libre/PKGBUILD b/libre/abiword-libre/PKGBUILD
index e8f1e00d8..7816107b7 100644
--- a/libre/abiword-libre/PKGBUILD
+++ b/libre/abiword-libre/PKGBUILD
@@ -14,18 +14,27 @@ url="http://www.abisource.com"
makedepends=('pkgconfig' 'asio' 'boost' 'fribidi' 'goffice0.8' 'libwmf' 'wv' 'link-grammar' 'gtkmathview'
'aiksaurus' 'libxslt' 'enchant' 'libots' 'libwpg' 'librsvg' 'loudmouth' 'libsoup' 'psiconv' 'ttf-liberation')
options=('!makeflags' '!libtool')
-source=(http://www.abisource.com/downloads/${_pkgbase}/${pkgver}/source/${_pkgbase}-${pkgver}.tar.gz
+mksource=(http://www.abisource.com/downloads/${_pkgbase}/${pkgver}/source/${_pkgbase}-${pkgver}.tar.gz
+ liberation-fonts.patch)
+source=(https://repo.parabolagnulinux.org/sources/${pkgbase}-${pkgver}.tar.gz
compat_libwpg_0_9.patch
- abiword-2.8.6-no-undefined.patch
+ abiword-2.8.6-no-undefined.patch
abiword-2.8.6-libpng15.patch
- abiword-2.8.6-glib-2.31.patch
- liberation-fonts.patch)
-md5sums=('f883b0a7f26229a9c66fd6a1a94381aa'
+ abiword-2.8.6-glib-2.31.patch)
+mkmd5sums=('f883b0a7f26229a9c66fd6a1a94381aa'
+ '880b17db6f249d977d2a7cd012d9ce02')
+md5sums=('0f943752f261725ba96d445d74578203'
'09446a2ebba8288fc611e88f7cf17298'
'42e2614b6e0aad457d91f6ce20b6f225'
'40e370e7e88c5437140ef18037abfbd3'
- '6ec338a27a6fb590c348724ddb545849'
- '880b17db6f249d977d2a7cd012d9ce02')
+ '6ec338a27a6fb590c348724ddb545849')
+
+mksource() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+
+ # Replace nonfree fonts support to liberation fonts
+ patch -Np1 -i "${srcdir}/liberation-fonts.patch"
+}
build() {
cd "${srcdir}/${_pkgbase}-${pkgver}"
@@ -38,9 +47,6 @@ build() {
# Fix build with recent glib, patch from Gentoo
patch -Np0 -i "${srcdir}/abiword-2.8.6-glib-2.31.patch"
- # Replace non-free fonts support to liberation fonts
- patch -Np1 -i "${srcdir}/liberation-fonts.patch"
-
libtoolize --force
autoreconf
@@ -60,7 +66,7 @@ build() {
}
package_abiword-libre() {
- pkgdesc="A fully-featured word processor that doesn't recommend nonfree fonts"
+ pkgdesc="A fully-featured word processor, without nonfree fonts recommendation"
depends=('fribidi' 'wv' 'goffice0.8' 'librsvg' 'enchant' 'desktop-file-utils')
install=$pkgname.install
optdepends=('abiword-libre-plugins')