summaryrefslogtreecommitdiff
path: root/libre/abiword-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-06 14:53:47 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-06 14:53:47 -0200
commit838255d6fa178ad2d3511b2b225414313f240206 (patch)
treefbf38dd997ca5499b27bfdc6e09e99f4577ac951 /libre/abiword-libre/PKGBUILD
parentc13d9b3add1efde888af0cd299c54205f5ac6e6a (diff)
abiword-libre-2.8.6-8: updating revision
* Adjust dependency on goffice, fix compilation * Update Emulatorman's email on PKGBUILD
Diffstat (limited to 'libre/abiword-libre/PKGBUILD')
-rw-r--r--libre/abiword-libre/PKGBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/libre/abiword-libre/PKGBUILD b/libre/abiword-libre/PKGBUILD
index 4286d258a..9d1800989 100644
--- a/libre/abiword-libre/PKGBUILD
+++ b/libre/abiword-libre/PKGBUILD
@@ -1,28 +1,30 @@
-# $Id: PKGBUILD 146945 2012-01-19 14:58:28Z giovanni $
+# $Id: PKGBUILD 173824 2012-12-24 15:08:34Z jgc $
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Maël Lavault <moimael@neuf.fr>
-# Maintainer (Parabola): André Silva <andre.paulista@adinet.com.uy>
+# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
_pkgbase=abiword
pkgbase=abiword-libre
pkgname=('abiword-libre' 'abiword-libre-plugins')
pkgver=2.8.6
-pkgrel=7.1
+pkgrel=8
arch=('i686' 'x86_64' 'mips64el')
license=('GPL')
url="http://www.abisource.com"
-makedepends=('pkgconfig' 'asio' 'boost' 'fribidi' 'goffice' 'libwmf' 'wv' 'link-grammar' 'gtkmathview'
- 'aiksaurus' 'libxslt' 'enchant' 'libots' 'libwpg' 'librsvg' 'loudmouth' 'libsoup' 'ttf-liberation')
+makedepends=('pkgconfig' 'asio' 'boost' 'fribidi' 'goffice0.8' 'libwmf' 'wv' 'link-grammar' 'gtkmathview'
+ 'aiksaurus' 'libxslt' 'enchant' 'libots' 'libwpg' 'librsvg' 'loudmouth' 'libsoup' 'psiconv' 'ttf-liberation')
options=('!makeflags' '!libtool')
-source=("http://www.abisource.com/downloads/${_pkgbase}/${pkgver}/source/${_pkgbase}-${pkgver}.tar.gz"
- 'compat_libwpg_0_9.patch'
- 'abiword-2.8.6-no-undefined.patch'
- 'abiword-2.8.6-libpng15.patch'
- 'liberation-fonts.patch')
+source=(http://www.abisource.com/downloads/${_pkgbase}/${pkgver}/source/${_pkgbase}-${pkgver}.tar.gz
+ compat_libwpg_0_9.patch
+ abiword-2.8.6-no-undefined.patch
+ abiword-2.8.6-libpng15.patch
+ abiword-2.8.6-glib-2.31.patch
+ liberation-fonts.patch)
md5sums=('f883b0a7f26229a9c66fd6a1a94381aa'
'09446a2ebba8288fc611e88f7cf17298'
'42e2614b6e0aad457d91f6ce20b6f225'
'40e370e7e88c5437140ef18037abfbd3'
+ '6ec338a27a6fb590c348724ddb545849'
'880b17db6f249d977d2a7cd012d9ce02')
build() {
@@ -32,6 +34,11 @@ build() {
# fix a gcc 4.6.x build issue, patch from Fedora
patch -Np1 -i "${srcdir}/abiword-2.8.6-no-undefined.patch"
patch -Np0 -i "${srcdir}/abiword-2.8.6-libpng15.patch"
+
+ # Fix build with recent glib, patch from Gentoo
+ patch -Np0 -i "${srcdir}/abiword-2.8.6-glib-2.31.patch"
+
+ # Replace non-free fonts support to liberation fonts
patch -Np1 -i "${srcdir}/liberation-fonts.patch"
libtoolize --force
@@ -54,7 +61,7 @@ build() {
package_abiword-libre() {
pkgdesc="A fully-featured word processor that doesn't recommend unfree fonts"
- depends=('fribidi' 'wv' 'goffice' 'librsvg' 'enchant' 'desktop-file-utils')
+ depends=('fribidi' 'wv' 'goffice0.8' 'librsvg' 'enchant' 'desktop-file-utils')
install=$pkgname.install
optdepends=('abiword-libre-plugins')
conflicts=("abiword-libre-plugins<${pkgver}-${pkgrel}" 'abiword')