summaryrefslogtreecommitdiff
path: root/libre/abiword/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2019-02-27 07:44:10 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2019-02-27 07:44:10 -0500
commitb3433e77d323c1f3153faaa54f38dd8aabcd689c (patch)
tree9ac064f5b4d798e43f1e8e830f4a5cff365228b4 /libre/abiword/PKGBUILD
parentc9a20872234d3646527f7464c8ef85c48d4db326 (diff)
abiword-3.0.2-9.par1: rebuild
Diffstat (limited to 'libre/abiword/PKGBUILD')
-rw-r--r--libre/abiword/PKGBUILD61
1 files changed, 27 insertions, 34 deletions
diff --git a/libre/abiword/PKGBUILD b/libre/abiword/PKGBUILD
index 508668b00..1f30fcd37 100644
--- a/libre/abiword/PKGBUILD
+++ b/libre/abiword/PKGBUILD
@@ -6,23 +6,22 @@
# Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=abiword
-
pkgver=3.0.2
-pkgrel=8.parabola2
-arch=(i686 x86_64 armv7h)
-
-pkgdesc="Fully-featured word processor, without Google search engine and nonfree fonts support"
-url="https://www.abisource.com"
-license=(GPL)
-
-depends=(fribidi wv goffice librsvg enchant desktop-file-utils
- redland libical gtk-update-icon-cache loudmouth libwpg libwps libwmf link-grammar
- gtkmathview aiksaurus libxslt libsoup libots libgsf psiconv)
-makedepends=(pkgconfig asio boost gobject-introspection libwpd libwps python2-gobject python-gobject)
-conflicts=(abiword-plugins abiword-libre)
-replaces=(abiword-plugins abiword-libre)
+pkgrel=9
+pkgrel+=.par1
+pkgdesc='Fully-featured word processor'
+pkgdesc+=', without Google search engine and nonfree fonts support'
+arch=('x86_64')
+arch+=('i686' 'armv7h')
+license=('GPL')
+url='https://www.abisource.com'
+depends=('fribidi' 'wv' 'goffice' 'librsvg' 'enchant' 'desktop-file-utils'
+ 'redland' 'libical' 'gtk-update-icon-cache' 'loudmouth' 'libwpg' 'libwps' 'libwmf' 'link-grammar'
+ 'gtkmathview' 'aiksaurus' 'libxslt' 'libsoup' 'libots' 'libgsf' 'psiconv')
+makedepends=('pkgconfig' 'asio' 'boost' 'gobject-introspection' 'libwpd' 'libwps' 'python2-gobject' 'python-gobject')
+conflicts=('abiword-plugins' 'abiword-libre')
+replaces=('abiword-plugins' 'abiword-libre')
options=(!makeflags)
-
source=(https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
abiword-3.0.0-librevenge.patch
abiword-3.0.1-libwps-0.4.patch
@@ -50,35 +49,35 @@ prepare() {
cd $pkgname-$pkgver
# fix build with librevenge based import filters
- patch -Np0 -i $srcdir/abiword-3.0.0-librevenge.patch
+ patch -Np0 -i ../abiword-3.0.0-librevenge.patch
# Fix libwpd 0.4 detection
- patch -Np1 -i $srcdir/abiword-3.0.1-libwps-0.4.patch
+ patch -Np1 -i ../abiword-3.0.1-libwps-0.4.patch
# Fix python override code to work with Python 3.x
- patch -Np1 -i $srcdir/python-override.patch
+ patch -Np1 -i ../python-override.patch
# Fix black on black (FS#51667)
# http://bugzilla.abisource.com/show_bug.cgi?id=13815
- patch -Np1 -i $srcdir/bug13815.patch
-
- # Replace nonfree fonts support to liberation fonts
- patch -Np1 -i $srcdir/liberation-fonts.patch
+ patch -Np1 -i ../bug13815.patch
# Replace deprecated enchant functions
- patch -Np1 -i $srcdir/enchant-2.1.patch
+ patch -Np1 -i ../enchant-2.1.patch
# Replace deprecated libical functions
- patch -Np1 -i $srcdir/libical-deprecated.patch
+ patch -Np1 -i ../libical-deprecated.patch
+
+ # Replace nonfree fonts support to liberation fonts
+ patch -Np1 -i ../liberation-fonts.patch
# Fix incessant flickering
# https://bugzilla.abisource.com/show_bug.cgi?id=13791
# https://sources.debian.org/patches/abiword/3.0.2-6/
- patch -Np1 -i $srcdir/fix-flickering.patch
+ patch -Np1 -i ../fix-flickering.patch
# Install missing m4 file
- install -m644 $srcdir/aiksaurus-plugin.m4 plugins/aiksaurus/plugin.m4
- install -m644 $srcdir/command-plugin.m4 plugins/command/plugin.m4
+ install -m644 ../aiksaurus-plugin.m4 plugins/aiksaurus/plugin.m4
+ install -m644 ../command-plugin.m4 plugins/command/plugin.m4
# Generate m4 file for configure
find plugins -name plugin.m4 | xargs cat > plugin-configure.m4
@@ -90,14 +89,12 @@ prepare() {
autoreconf -fi
}
-
build() {
cd $pkgname-$pkgver
# `--enable-plugins` has the complete list of plugins, except for
# 'command', 'gda', 'google', and 'rsvg'.
- ./configure \
- --prefix=/usr \
+ ./configure --prefix=/usr \
--enable-shared \
--disable-static \
--enable-clipart \
@@ -109,19 +106,15 @@ build() {
passepartout pdb pdf presentation psion s5 sdw t602 urldict \
wikipedia wmf wml wordperfect wpg xslfo" \
--enable-introspection
-
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
make
}
package() {
cd $pkgname-$pkgver
-
make DESTDIR="$pkgdir" install
cd src/gi-overrides
sed -i 's/python -c/python2 -c/' Makefile
-
make DESTDIR="$pkgdir" PYTHON=python2 install
}