summaryrefslogtreecommitdiff
path: root/libre/atool-libre/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-07-19 15:31:13 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-07-19 15:31:13 -0300
commit4d2780093ffab5e298e62454d2792f3e39512188 (patch)
tree1a27ddff0f6eee3ad10af1768a86bafab9fba7b1 /libre/atool-libre/PKGBUILD
parent9cfece7660a5dd3c41b6ed1dd06a1b8b4b4bc420 (diff)
libre/atool-libre
Diffstat (limited to 'libre/atool-libre/PKGBUILD')
-rw-r--r--libre/atool-libre/PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/libre/atool-libre/PKGBUILD b/libre/atool-libre/PKGBUILD
new file mode 100644
index 000000000..295e67725
--- /dev/null
+++ b/libre/atool-libre/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id: PKGBUILD 10828 2010-02-02 18:05:28Z jlichtblau $
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: leif_thande <leif.thande@gmail.com>
+# Contributor: tranquility <trankas@gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+_pkgname=atool
+pkgname=atool-libre
+pkgver=0.37.0
+pkgrel=4
+pkgdesc="A script for managing file archives of various types"
+arch=('any')
+url="http://www.nongnu.org/atool/"
+license=('GPL3')
+depends=('file' 'perl')
+provides=("$_pkgname=$pkgver")
+replaces=("$_pkgname")
+conflicts=("$_pkgname")
+optdepends=('bzip2: for using atool with bzip2 compressed archives'
+ 'cpio: for using atool with cpio archives'
+ 'gzip: for using atool with gzip compressed archives'
+ 'lha: for using atool with lha, lharc and similar archives'
+ 'lzma-utils: for using atool with lzma compressed archives'
+ 'lzop: for using atool with lzop compressed archives'
+ 'p7zip: for using atool with 7z archives'
+ 'tar: for using atool with tar archives'
+ 'zip: for using atool for creating zip archives'
+ 'unzip: for using atool for unpacking archives')
+source=(http://savannah.nongnu.org/download/atool/atool-${pkgver}.tar.gz)
+md5sums=('2607e9b19518af4145be8a6bed454477')
+
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ make prefix=${pkgdir}/usr install || return 1
+}
+