summaryrefslogtreecommitdiff
path: root/libre/audacious-plugins-libre/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-03-17 12:58:26 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-03-17 12:58:26 -0300
commit2ec8cce100bb5196b26f4c450c13f3ec779269b6 (patch)
tree8c1954b73941fed5511c5a15c84bb5faf64238ef /libre/audacious-plugins-libre/PKGBUILD
parent7465d8ef280ddd7cb3d70d144e169e7f9bfaa6e9 (diff)
[audacious-plugins-libre] Renamed dir
Diffstat (limited to 'libre/audacious-plugins-libre/PKGBUILD')
-rw-r--r--libre/audacious-plugins-libre/PKGBUILD83
1 files changed, 83 insertions, 0 deletions
diff --git a/libre/audacious-plugins-libre/PKGBUILD b/libre/audacious-plugins-libre/PKGBUILD
new file mode 100644
index 000000000..aca8c9a8d
--- /dev/null
+++ b/libre/audacious-plugins-libre/PKGBUILD
@@ -0,0 +1,83 @@
+# $Id$
+# Contributor: Alexander Fehr <pizzapunk gmail com>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgname=audacious-plugins-libre
+pkgver=2.4.4
+pkgrel=2
+pkgdesc='Plugins for Audacious without unfree plugins'
+arch=('i686' 'x86_64')
+url='http://audacious-media-player.org/'
+license=('GPL')
+provides=("audacious-plugins=$pkgver")
+replaces=("${pkgname%-libre}")
+conflicts=("${pkgname%-libre}")
+
+makedepends=("audacious>=${pkgver}"
+ 'alsa-lib' 'pulseaudio' 'jack' 'lame' 'libvorbis' 'flac'
+ 'faad2' 'ffmpeg' 'fluidsynth' 'libcdio' 'libsidplay' 'wavpack'
+ 'libnotify' 'lirc-utils' 'curl' 'libmtp'
+ 'neon' 'libmms' 'libcue')
+
+optdepends=('alsa-lib: Advanced Linux Sound Arch. output'
+ 'pulseaudio: PulseAudio output'
+ 'jack: Jack Audio Connection Kit output'
+ 'lame: FileWriter MP3 output'
+ 'libvorbis: Vorbis input, FileWriter Vorbis output'
+ 'flac: FLAC input, FileWriter FLAC output'
+
+ 'faad2: AAC input'
+ 'ffmpeg: ffaudio input'
+ 'fluidsynth: MIDI FluidSynth backend input'
+ 'libcdio: CD Digital Audio input'
+ 'libsidplay: Commodore 64 audio input'
+ 'wavpack: WavPack input'
+
+ 'libnotify: libnotify OSD'
+ 'lirc-utils: LIRC'
+ 'curl: AudioScrobbler Client'
+ 'libmtp: Upload to MTP device'
+
+ 'neon: neon-based http transport'
+ 'libmms: libmms-based mms transport'
+ 'libcue: CUE playlist format')
+
+source=("http://repo.parabolagnulinux.org/other/$pkgname-$pkgver.tar.gz")
+
+# Source PKGBUILD and run this function from the shell
+mksource(){
+ tmpdir=$(mktemp -d /tmp/audacious-XXXX)
+ pushd $tmpdir >/dev/null
+ wget "http://distfiles.atheme.org/${pkgname%-libre}-$pkgver.tgz" -O - -q | tar xzf -
+
+ rm -rvf ${pkgname%-libre}-$pkgver/src/{u,p}sf/
+
+ mv -v ${pkgname%-libre}-$pkgver ${pkgname}-$pkgver
+
+ tar czf ${pkgname}-${pkgver}.tar.gz ${pkgname}-${pkgver}/
+
+ echo "You can find the sources at $tmpdir"
+
+ popd >/dev/null
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure \
+ --build=$CHOST \
+ --host=$CHOST \
+ --target=$CHOST \
+ --prefix=/usr \
+ --enable-chardet \
+ --enable-amidiplug \
+ --disable-adplug \
+ --disable-psf
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums=('df761a2d07e2ad1221c5fe61fa32dcb0')