summaryrefslogtreecommitdiff
path: root/libre/audacious-plugins-libre/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-09-03 19:08:01 -0300
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-09-03 19:08:01 -0300
commit4ae7bcc01726f4da6d3a7d34ca37813ecd9ca209 (patch)
tree290ef007932a2e9d03db98e2d810cd5c68b515cd /libre/audacious-plugins-libre/PKGBUILD
parent369dde3f21cde189d173c347d92276dad2a8bab4 (diff)
rename to audacious-plugins
Diffstat (limited to 'libre/audacious-plugins-libre/PKGBUILD')
-rw-r--r--libre/audacious-plugins-libre/PKGBUILD127
1 files changed, 0 insertions, 127 deletions
diff --git a/libre/audacious-plugins-libre/PKGBUILD b/libre/audacious-plugins-libre/PKGBUILD
deleted file mode 100644
index 323eee1c4..000000000
--- a/libre/audacious-plugins-libre/PKGBUILD
+++ /dev/null
@@ -1,127 +0,0 @@
-# $Id: PKGBUILD 217506 2014-07-20 21:57:27Z bisson $
-# Maintainer (Arch): Gaetan Bisson <bisson@archlinux.org>
-# Contributor (Arch): Alexander Fehr <pizzapunk gmail com>
-# Contributor (Arch): William Rea <sillywilly@gmail.com>
-# Maintainer (Arch): Gaetan Bisson <bisson@archlinux.org>
-# Maintainer: Brendan Tildesley
-# Contributor: Jorge Lopez <jorginho@parabola.nu>
-
-_pkgname=audacious-plugins
-pkgname=audacious-plugins-libre
-pkgver=3.5.1
-pkgrel=1
-pkgdesc='Plugins for Audacious, without nonfree plugins'
-url='http://audacious-media-player.org/'
-license=('GPL' 'GPL3' 'LGPL' 'custom:BSD')
-arch=('i686' 'x86_64' 'mips64el')
-
-# Licensing issues:
-# The plugins 'scrobbler', stereoplugin', 'wavepack' and 'plugin_echo' have no license notice
-# but I've been informed by an upstream dev, nenolod, that they are all GPL. I don't know what version
-#
-# The plugin 'psf' is under BSD license, mostly, but it uses code from PeOPS, so it's probably GPL.
-# However, 'psf' is apparently an emulator for running nonfree code, so I'm not rushing to fix it.
-#
-# All the other custom licensed plugins I think are mostly modified BSD or ISC.
-
-replaces=($_pkgname)
-conflicts=($_pkgname)
-provides=($_pkgname=$pkgver)
-
-makedepends=("audacious>=${pkgver}"
- 'glib2' 'python2' # for gdbus-codegen
- 'alsa-lib' 'pulseaudio' 'jack2' 'lame' 'libvorbis' 'flac'
- 'mpg123' 'faad2' 'ffmpeg' 'libmodplug' 'fluidsynth' 'libcdio-paranoia' 'libsidplayfp' 'wavpack'
- 'dbus-glib' 'libnotify' 'lirc-utils' 'curl' 'libmtp'
- 'neon' 'libmms' 'libcue')
-
-optdepends=('alsa-lib: Advanced Linux Sound Arch. output'
- 'pulseaudio: PulseAudio output'
- 'jack2: Jack Audio Connection Kit output'
- 'lame: FileWriter MP3 output'
- 'libvorbis: Vorbis input, FileWriter Vorbis output'
- 'flac: FLAC input, FileWriter FLAC output'
-
- 'mpg123: MP3 input'
- 'faad2: AAC input'
- 'ffmpeg: ffaudio input'
- 'libmodplug: modplug input'
- 'fluidsynth: MIDI FluidSynth backend input'
- 'libcdio-paranoia: CD Digital Audio input'
- 'libsidplayfp: Commodore 64 audio input'
- 'wavpack: WavPack input'
-
- 'dbus-glib: Gnome Shortcuts Plugin'
- 'libnotify: libnotify OSD'
- 'lirc-utils: LIRC'
- 'curl: AudioScrobbler Client'
- 'libmtp: Upload to MTP device'
-
- 'neon: neon-based http transport'
- 'libmms: libmms-based mms transport'
- 'libcue: CUE playlist format')
-
-source=("http://distfiles.audacious-media-player.org/${_pkgname}-${pkgver}.tar.bz2")
-sha1sums=('c066f79ca1f213c998b651250d02a84982556946')
-
-prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
-
- # Retrieve upstream & remove plugin 'psf' due to issues mentioned above.
- rm -rv src/psf
- sed -i s/enable_psf=yes/enable_psf=no/ configure
-
- # Get license notices out of custom-licensed packages
- cd src
- tmpdir=$(mktemp -d /tmp/${_pkgname}-${pkgver}-XXXX)
- head -n 18 albumart/albumart.c | cut -c 4- | tail -n 17 > ${tmpdir}/LICENSE.albumart
- head -n 17 alsa/alsa.c | cut -c 4- | tail -n 16 > ${tmpdir}/LICENSE.alsa
- head -n 17 audpl/audpl.c | cut -c 4- | tail -n 16 > ${tmpdir}/LICENSE.audpl
- head -n 18 cairo-spectrum/cairo-spectrum.c | cut -c 4- | tail -n 17 > ${tmpdir}/LICENSE.cairo-spectrum
- head -n 17 compressor/compressor.c | cut -c 4- | tail -n 16 > ${tmpdir}/LICENSE.compressor
- head -n 17 crossfade/crossfade.c | cut -c 4- | tail -n 16 > ${tmpdir}/LICENSE.crossfade
- head -n 18 crystalizer/crystalizer.c | cut -c 4- | tail -n 17 > ${tmpdir}/LICENSE.crystalizer
- head -n 18 lyricwiki/lyricwiki.c | cut -c 4- | tail -n 17 > ${tmpdir}/LICENSE.lyricwiki
- head -n 19 mpg123/mpg123.c | cut -c 4- | tail -n 18 > ${tmpdir}/LICENSE.mpg123
- head -n 17 mpris2/plugin.c | cut -c 4- | tail -n 16 > ${tmpdir}/LICENSE.mpris2
- head -n 17 resample/resample.c | cut -c 4- | tail -n 16 > ${tmpdir}/LICENSE.resample
- head -n 17 unix-io/unix-io.c | cut -c 4- | tail -n 16 > ${tmpdir}/LICENSE.unix-io
- head -n 18 voice_removal/voice_removal.c | cut -c 4- | tail -n 17 > ${tmpdir}/LICENSE.voice_removal
- head -n 25 xsf/corlett.c | cut -c 2- | tail -n 23 > ${tmpdir}/LICENSE.xfs
- l=${pkgdir}/usr/share/licenses/${pkgname}/
- install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
- cd ..
- pushd $tmpdir
- install -m644 LICENSE.albumart $l
- install -m644 LICENSE.alsa $l
- install -m644 LICENSE.audpl $l
- install -m644 LICENSE.cairo-spectrum $l
- install -m644 LICENSE.compressor $l
- install -m644 LICENSE.crossfade $l
- install -m644 LICENSE.crystalizer $l
- install -m644 LICENSE.lyricwiki $l
- install -m644 LICENSE.mpg123 $l
- install -m644 LICENSE.mpris2 $l
- install -m644 LICENSE.resample $l
- install -m644 LICENSE.unix-io $l
- install -m644 LICENSE.voice_removal $l
- install -m644 LICENSE.xfs $l
- popd
-}
-
-build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
-
- ./configure \
- --prefix=/usr \
- --enable-amidiplug \
- --disable-adplug \
-
- make
-}
-
-package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}