summaryrefslogtreecommitdiff
path: root/libre/blender-libre/PKGBUILD
diff options
context:
space:
mode:
authorMárcio Alexandre Silva Delgado <coadde@adinet.com.uy>2012-07-15 15:45:11 -0300
committerMárcio Alexandre Silva Delgado <coadde@adinet.com.uy>2012-07-15 15:45:11 -0300
commita8a2c7388922e286a6aa4bbd388a128aef9c720b (patch)
treef006a9dc2d339114c45814001d85906b00369bbb /libre/blender-libre/PKGBUILD
parentde9ab185a1c49d54b0ab5cee79f016d663d90b10 (diff)
blender-libre: updating package
Diffstat (limited to 'libre/blender-libre/PKGBUILD')
-rw-r--r--libre/blender-libre/PKGBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/libre/blender-libre/PKGBUILD b/libre/blender-libre/PKGBUILD
index 5dd14405d..b4ba9f827 100644
--- a/libre/blender-libre/PKGBUILD
+++ b/libre/blender-libre/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=blender
pkgname=blender-libre
pkgver=2.63a
-pkgrel=2.1
+pkgrel=3
epoch=4
pkgdesc="A fully integrated 3D graphics creation suite (without nonfree cuda-toolkit support)"
arch=('i686' 'x86_64' 'mips64el')
@@ -18,15 +18,19 @@ makedepends=('cmake' 'boost')
replaces=("${_pkgname}")
conflicts=("${_pkgname}")
provides=("${_pkgname}=${pkgver}")
-options=(!strip)
install=${_pkgname}.install
-source=(http://download.${_pkgname}.org/source/${_pkgname}-${pkgver}.tar.gz ffmpeg-0.11.patch)
-md5sums=('31a60b3ce5466d965cb7e2648995e092' '9e5649403e51654615d30b10bc460217')
+source=(http://download.${_pkgname}.org/source/${_pkgname}-${pkgver}.tar.gz
+ ffmpeg-0.11.patch
+ boost-1.50.patch)
+md5sums=('31a60b3ce5466d965cb7e2648995e092'
+ '9e5649403e51654615d30b10bc460217'
+ '0bab80da07d980c47b8ce3cb998edaef')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -Np1 < "${srcdir}"/ffmpeg-0.11.patch
+ patch -Np1 < "${srcdir}"/boost-1.50.patch
sed -i "/<libavcodec\/opt.h>/d" intern/ffmpeg/ffmpeg_compat.h
sed -i "/<libavcodec\/opt.h>/d" source/blender/blenkernel/intern/writeffmpeg.c
@@ -60,10 +64,6 @@ build() {
make $MAKEFLAGS
-# cp -rf "${srcdir}/${_pkgname}-${pkgver}"/release/plugins/* \
-# "${srcdir}/${_pkgname}-${pkgver}"/source/blender/blenpluginapi/
-# cd "${srcdir}/${_pkgname}-${pkgver}"/source/blender/blenpluginapi
-# chmod 755 bmake
make
}
@@ -71,11 +71,4 @@ package() {
cd "${srcdir}/${_pkgname}-${pkgver}/build"
make DESTDIR="${pkgdir}" install
python -m compileall "${pkgdir}/usr/share/blender"
-
-# install plugins
-# install -d -m755 "${pkgdir}"/usr/share/blender/${pkgver%[a-z]}/plugins/{sequence,texture}
-# cp "${srcdir}/${_pkgname}-${pkgver}"/source/blender/blenpluginapi/sequence/*.so \
-# "${pkgdir}"/usr/share/blender/${pkgver%[a-z]}/plugins/sequence/
-# cp "${srcdir}/${_pkgname}-${pkgver}"/source/blender/blenpluginapi/texture/*.so \
-# "${pkgdir}"/usr/share/blender/${pkgver%[a-z]}/plugins/texture/
}