summaryrefslogtreecommitdiff
path: root/libre/bogofilter-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-01-09 07:12:45 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-01-09 07:12:45 -0200
commit0be54df3f3279c4397e0db0a90656df948c030ce (patch)
tree5f21ee053031eebac93a803ddcddb937980bf315 /libre/bogofilter-libre/PKGBUILD
parentf6012738c70d4991d4e55d20379b4a4c92ed48f7 (diff)
bogofilter-libre: add mksource
Diffstat (limited to 'libre/bogofilter-libre/PKGBUILD')
-rw-r--r--libre/bogofilter-libre/PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/libre/bogofilter-libre/PKGBUILD b/libre/bogofilter-libre/PKGBUILD
index 0535d872f..308fc6f3b 100644
--- a/libre/bogofilter-libre/PKGBUILD
+++ b/libre/bogofilter-libre/PKGBUILD
@@ -13,17 +13,23 @@ license=('GPL3')
url="http://bogofilter.sourceforge.net"
depends=('db' 'perl' 'gsl')
backup=('etc/bogofilter/bogofilter.cf')
-source=(http://sourceforge.net/projects/${_pkgname}/files/${_pkgname}-current/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}.tar.bz2)
-md5sums=('d0a5eebb3274b23ceabe766a6443a1c5')
+mksource=(http://sourceforge.net/projects/${_pkgname}/files/${_pkgname}-current/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}.tar.bz2)
+source=(https://repo.parabolagnulinux.org/sources/${pkgname}-${pkgver}.tar.bz2)
+mkmd5sums=('d0a5eebb3274b23ceabe766a6443a1c5')
+md5sums=('cce573e059d39a68cf78097dbfaa5b2d')
provides=("${_pkgname}=${pkgver}")
replaces=("${_pkgname}")
conflicts=("${_pkgname}")
-build() {
+mksource() {
cd ${_pkgname}-${pkgver}
# Remove noncommercial files.
rm doc/bogofilter-SA-{2005-0{1,2},2010-01}
+}
+
+build() {
+ cd ${_pkgname}-${pkgver}
./configure --prefix=/usr \
--sysconfdir=/etc/bogofilter \