summaryrefslogtreecommitdiff
path: root/libre/epdfview/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-09-04 02:29:56 -0300
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-09-04 02:29:56 -0300
commitdcb9f94b1f184a61c9838b20919eef1842a07091 (patch)
tree96f4746cd14de68b4ed56a8536ab444df2a6b01b /libre/epdfview/PKGBUILD
parentfc353061e3e6b3e8542d2000b89ca2ecfc604b1b (diff)
rename to epdfview
Diffstat (limited to 'libre/epdfview/PKGBUILD')
-rw-r--r--libre/epdfview/PKGBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/libre/epdfview/PKGBUILD b/libre/epdfview/PKGBUILD
new file mode 100644
index 000000000..adef21e0e
--- /dev/null
+++ b/libre/epdfview/PKGBUILD
@@ -0,0 +1,57 @@
+# $Id: PKGBUILD 105182 2014-02-02 12:39:48Z bpiotrowski $
+# Maintainer (Arch): Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Maintainer (Arch): Kyle Keen <keenerd@gmail.com>
+# Contributor (Arch): schuay <jakob.gruber@gmail.com>
+# Contributor (Arch): Tom K <tomk@runbox.com>
+# Contributor (Arch): Thayer Williams <thayer@archlinux.org>
+# Maintainer: Márcio Silva <coadde@parabola.nu>
+# Maintainer: Michał Masłowski <mtjm@mtjm.eu>
+
+pkgname=epdfview
+pkgver=0.1.8
+pkgrel=5.parabola1
+pkgdesc='Lightweight PDF document viewer, without nonfree suggestions'
+url="http://freecode.com/projects/$pkgname"
+arch=('i686' 'x86_64' 'mips64el')
+license=('GPL')
+depends=('poppler-glib' 'desktop-file-utils' 'hicolor-icon-theme' 'gtk2' 'xdg-utils')
+makedepends=('pkgconfig')
+conflicts=("$pkgname-libre")
+replaces=("$pkgname-libre")
+install="$pkgname.install"
+source=(ftp://ftp.slackware.com/.1/blfs/conglomeration/$pkgname/$pkgname-$pkgver.tar.bz2
+ $pkgname-0.1.8-swap-the-blue-and-red-channel.patch
+ $pkgname-0.1.8-glib2-headers.patch
+ $pkgname-0.1.8-modern-cups.patch)
+md5sums=('e50285b01612169b2594fea375f53ae4'
+ '7f9ea101a41f5b4e999fd024f423d41f'
+ '2fffa9c7cd4c5f0744803591c2f162a3'
+ '5c2cf5612d2a7dfe6cf005b94aeb5ada')
+
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i "s/icon_$pkgname-48/$pkgname/" data/$pkgname.desktop
+
+ # Use xdg-open as default browser.
+ sed -r '/DEFAULT_EXTERNAL_BROWSER_COMMAND_LINE/s/firefox[^ ]*/xdg-open/' -i src/Config.cxx
+
+ patch -p1 -i ../$pkgname-0.1.8-swap-the-blue-and-red-channel.patch
+ patch -p1 -i ../$pkgname-0.1.8-glib2-headers.patch # FS#30116
+ patch -p1 -i ../$pkgname-0.1.8-modern-cups.patch # FS#32511
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ for size in 24 32 48; do
+ install -Dm644 data/icon_$pkgname-$size.png \
+ "$pkgdir"/usr/share/icons/hicolor/${size}x${size}/apps/$pkgname.png
+ done
+}