summaryrefslogtreecommitdiff
path: root/libre/file-roller/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-02 06:41:22 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-02 06:41:22 -0300
commitfcce4e670cd2d81990b3f50e8a682b44d40a73cc (patch)
tree2634d6d68316f3f4dd51f378e826da884a919288 /libre/file-roller/PKGBUILD
parentc5822ca785d156da9849d5e25dc79a93d1fac22d (diff)
remove parabola suffix and add complex pkgrel on the packages
Diffstat (limited to 'libre/file-roller/PKGBUILD')
-rw-r--r--libre/file-roller/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/libre/file-roller/PKGBUILD b/libre/file-roller/PKGBUILD
new file mode 100644
index 000000000..937f02cba
--- /dev/null
+++ b/libre/file-roller/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 213482 2014-05-23 23:43:56Z heftig $
+# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor (Arch): Jan de Groot <jgc@archlinux.org>
+
+pkgname=file-roller
+pkgver=3.12.2
+pkgrel=1.parabola1
+pkgdesc="Create and modify archives, with unar support included and nonfree unace recommendation removed"
+arch=('i686' 'x86_64' 'mips64el')
+license=('GPL')
+depends=('desktop-file-utils' 'gtk3' 'hicolor-icon-theme' 'dconf' 'libarchive' 'file' 'json-glib' 'libnotify' 'p7zip' 'unar')
+makedepends=('intltool' 'gnome-doc-utils' 'pkg-config' 'libnautilus-extension' 'itstool' 'docbook-xsl')
+optdepends=('lrzip: lrzip archive support')
+groups=('gnome-extra')
+replaces=("${pkgname}-libre" "${pkgname}-parabola")
+conflicts=("${pkgname}-libre" "${pkgname}-parabola")
+options=('!emptydirs')
+install=file-roller.install
+url="http://www.gnome.org"
+source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
+sha256sums=('0677be6618dba609eae2d76420e8a5a8d9a414bcec654e7b71e65b941764eacf')
+
+build() {
+ cd $pkgname-$pkgver
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --libexecdir=/usr/lib/file-roller \
+ --localstatedir=/var --disable-static \
+ --disable-schemas-compile
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}