summaryrefslogtreecommitdiff
path: root/libre/filesystem/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-04-01 06:57:32 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-04-01 07:22:42 -0300
commit70df29221fa3ef65ad6d8033f0b85a87c147104a (patch)
tree5451f3e1b06d69ee423ccf40380fe038d2cba142 /libre/filesystem/PKGBUILD
parent94e9752b2bbbbe1c59feca70c2d5e33dafd896f7 (diff)
filesystem-2017.03-2.parabola1: updating version
Diffstat (limited to 'libre/filesystem/PKGBUILD')
-rw-r--r--libre/filesystem/PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/libre/filesystem/PKGBUILD b/libre/filesystem/PKGBUILD
index d2b2d8aca..8adc24971 100644
--- a/libre/filesystem/PKGBUILD
+++ b/libre/filesystem/PKGBUILD
@@ -1,12 +1,12 @@
-# $Id: PKGBUILD 282858 2016-12-05 23:47:36Z seblu $
+# $Id: PKGBUILD 291699 2017-03-26 22:06:04Z seblu $
# Maintainer (Arch): Sébastien Luttringer
# Contributor (Arch): Tom Gundersen <teg@jklm.no>
# Maintainer: Nicolás Reynolds <fauno@kiwwwi.com.ar>
# Maintainer: André Silva <emulatorman@parabola.nu>
pkgname=filesystem
-pkgver=2016.12
-pkgrel=2.parabola2
+pkgver=2017.03
+pkgrel=2.parabola1
pkgdesc='Base Parabola GNU/Linux-libre files (Parabola rebranded)'
arch=('i686' 'x86_64' 'armv7h')
license=('GPL')
@@ -23,22 +23,22 @@ backup=('etc/fstab' 'etc/crypttab' 'etc/group' 'etc/hosts' 'etc/ld.so.conf' 'etc
source=('group' 'issue' 'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
'passwd' 'shadow' 'fstab' 'crypttab' 'hosts' 'motd' 'os-release' 'resolv.conf'
'shells' 'gshadow' 'profile' 'parabola.7.txt' 'locale.sh')
-md5sums=('4d7417d2bf8872665c0907f09ae37c34'
+md5sums=('76c80215d8dd395d3be4b8a711d585b6'
'6be47d893fd49b2e4a8c0e811b350861'
'7b21f0f97f048988908bf93778bba65f'
'4c4540eeb748bf1f71d631b8c1dcf0b3'
'f28150d4c0b22a017be51b9f7f9977ed'
'6e488ffecc8ba142c0cf7e2d7aeb832e'
- 'a998d1e6c7cc5791a7f4a2b49b2d10ce'
- '1ec1b16e2a71fad63ab8f147069a5d97'
+ 'cb1a751b05541d8eebaace316de0e809'
+ 'c0c27476ee248355bf308c8502a8c860'
'693c97f2c9a519bb97a17008e92c2b74'
'49639d107b75fe4e668ae27749da32ab'
'7bc65f234dfb6abf24e7c3b03e86f4ff'
'd41d8cd98f00b204e9800998ecf8427e'
- '83e0de34441a56684db8f813099d62f8'
+ '24f9ba68a8fea07621d68f77584a1c69'
'6f48288b6fcaf0065fcb7b0e525413e0'
'22518e922891f9359f971f4f5b4e793c'
- '69e460404f45bdb7288d1de662e56dd9'
+ 'c08581d4f982be8806d3afa912a65203'
'cfa3345c485c59e681ab39a44dc7ece1'
'd5732ffdb3488e1383d4ea199343e767'
'71ed98c52e11ada1f936ac8cb14eecd9')
@@ -92,14 +92,16 @@ package() {
# vsftpd won't run with write perms on /srv/ftp
install -d -m555 -g ftp srv/ftp
- # setup /etc
- install -d etc/{ld.so.conf.d,skel,profile.d}
+ # setup /etc and /usr/share/factory/etc
+ install -d etc/{ld.so.conf.d,skel,profile.d} usr/share/factory/etc
for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf passwd resolv.conf securetty shells profile; do
install -m644 "$srcdir"/$f etc/
+ install -m644 "$srcdir"/$f usr/share/factory/etc/
done
- ln -s /proc/self/mounts etc/mtab
+ ln -s ../proc/self/mounts etc/mtab
for f in gshadow shadow crypttab; do
install -m600 "$srcdir"/$f etc/
+ install -m600 "$srcdir"/$f usr/share/factory/etc/
done
touch etc/parabola-release
ln -sv parabola-release etc/arch-release
@@ -156,4 +158,7 @@ package() {
install -d -m755 usr/local/$d
done
ln -s ../man usr/local/share/man
+
+ # remove conflict with systemd
+ rm usr/share/factory/etc/nsswitch.conf
}