summaryrefslogtreecommitdiff
path: root/libre/gnu-ghostscript/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-01-22 16:18:07 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-01-22 16:18:07 -0200
commit868dad272a6099b9dcdaf0264fffa34e67eeea5c (patch)
tree30c4eb0bf94d2f6b713efb365ebb99d5dc9d429d /libre/gnu-ghostscript/PKGBUILD
parentc87a3442b8df14ac47eedfedf427f37be8f1e9a5 (diff)
gnu-ghostscript-9.06.0-7: updating revision
* go back to bundled heavily patched openjpeg source to solve some segfaults, FS#38226 => https://bugs.archlinux.org/task/38226 * add libpaper support; use gtk3 for gsx
Diffstat (limited to 'libre/gnu-ghostscript/PKGBUILD')
-rw-r--r--libre/gnu-ghostscript/PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/libre/gnu-ghostscript/PKGBUILD b/libre/gnu-ghostscript/PKGBUILD
index f23b29ec0..817e6a418 100644
--- a/libre/gnu-ghostscript/PKGBUILD
+++ b/libre/gnu-ghostscript/PKGBUILD
@@ -2,25 +2,25 @@
_pkgname=ghostscript
pkgname=gnu-ghostscript
-_gspkgver=9.10 # ghostscript package version
+_gspkgver=9.10 # ghostscript-libre package version
_pkgver=9.06
pkgver=9.06.0
-pkgrel=6
+pkgrel=7
pkgdesc="An interpreter for the PostScript language maintained by a team of GNU programmers"
arch=('i686' 'x86_64' 'mips64el')
license=('GPL3')
depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg'
- 'libtiff>=4.0.0' 'lcms2' 'dbus')
-makedepends=('gtk2' 'gnutls' 'openjpeg')
+ 'libtiff>=4.0.0' 'lcms2' 'dbus' 'libpaper')
+makedepends=('gtk3' 'gnutls')
optdepends=('texlive-core: needed for dvipdf'
- 'gtk2: needed for gsx')
+ 'gtk3: needed for gsx')
conflicts=${_pkgname}
provides="${_pkgname}=${_gspkgver}"
url="https://www.gnu.org/software/${_pkgname}/"
source=(ftp://ftp.gnu.org/gnu/${_pkgname}/${pkgname}-${pkgver}.tar.xz
ijs-automake.patch
libtool.patch)
-options=('!libtool' '!makeflags')
+options=('!makeflags')
md5sums=('85a5e07a6b91937c157576293b381065'
'83bcae456ad4c9fb790be483914dbeba'
'5bd5d4966007b460deed866a30a0b3c8')
@@ -35,7 +35,9 @@ build() {
patch -Np1 -i ${srcdir}/libtool.patch
# force it to use system-libs
- rm -rf jpeg libpng zlib jasper expat tiff lcms lcms2 freetype openjpeg cups/libs # jbig2dec is in community
+ # keep heavily patched included openjpeg, leads to segfault with system openjpeg
+ # https://bugs.archlinux.org/task/38226
+ rm -rf jpeg libpng zlib jasper expat tiff lcms lcms2 freetype cups/libs # jbig2dec is in community
./configure --prefix=/usr \
--enable-dynamic \
@@ -45,12 +47,13 @@ build() {
--with-x \
--with-drivers=ALL\
--with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
- --with-install-cups \
--enable-fontconfig \
--enable-freetype \
+ --enable-openjpeg \
--without-luratech \
--without-omni \
--with-system-libtiff \
+ --with-libpaper \
--disable-compile-inits #--help # needed for linking with system-zlib
make