summaryrefslogtreecommitdiff
path: root/libre/gnu-ghostscript/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-11-02 17:08:30 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-11-02 17:08:30 -0200
commit99015cdc5145fd8c7e14ea76bcbd1d0ecb210ddd (patch)
treea27d3fa4cbf14b18d3caf352534037b3d07a6684 /libre/gnu-ghostscript/PKGBUILD
parent18c27dc5c8367400c3d6b9ef6a9417805c2ce62d (diff)
gnu-ghostscript-9.05.0-1: fixing issues
Diffstat (limited to 'libre/gnu-ghostscript/PKGBUILD')
-rwxr-xr-xlibre/gnu-ghostscript/PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/libre/gnu-ghostscript/PKGBUILD b/libre/gnu-ghostscript/PKGBUILD
index 4fb123c2c..9ff2da255 100755
--- a/libre/gnu-ghostscript/PKGBUILD
+++ b/libre/gnu-ghostscript/PKGBUILD
@@ -8,7 +8,7 @@ pkgrel=1
pkgdesc="An interpreter for the PostScript language created by the FSF"
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg' 'libtiff>=4.0.0' 'lcms') # 'lcms2' won't get used) # move in libpaper from community?
+depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg' 'libtiff>=4.0.0' 'lcms2')
makedepends=('gtk2' 'gnutls')
optdepends=('texlive-core: needed for dvipdf'
'gtk2: needed for gsx')
@@ -16,13 +16,18 @@ conflicts=${_pkgname}
replaces=${_pkgname}
provides=${_pkgname}
url="https://www.gnu.org/software/${_pkgname}/"
-source=(ftp://ftp.gnu.org/gnu/${_pkgname}/${pkgname}-${pkgver}.tar.xz)
+source=(ftp://ftp.gnu.org/gnu/${_pkgname}/${pkgname}-${pkgver}.tar.xz
+ libtool.patch)
options=('!libtool' '!makeflags')
-md5sums=('e80423be9abb32fc99cc897ed379a7df')
+md5sums=('e80423be9abb32fc99cc897ed379a7df'
+ '5bd5d4966007b460deed866a30a0b3c8')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
+ # fix libtool version
+ patch -Np1 -i ${srcdir}/libtool.patch
+
# force it to use system-libs
rm -rf jpeg libpng zlib jasper expat tiff lcms freetype