summaryrefslogtreecommitdiff
path: root/libre/icecat/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2022-10-08 09:29:39 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2022-10-09 08:47:20 -0400
commit3261a709c57480632f20ea6b84b2f1bdfbb0a027 (patch)
treec01d673fdfa25e8375eb03c4e830f65312d1013f /libre/icecat/PKGBUILD
parent53a108631de2993068455c0dd640fee7ecda4dfc (diff)
housekeeping - minimize diff between icecat and iceweasel
Diffstat (limited to 'libre/icecat/PKGBUILD')
-rw-r--r--libre/icecat/PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/libre/icecat/PKGBUILD b/libre/icecat/PKGBUILD
index 02ea629ce..9636fc209 100644
--- a/libre/icecat/PKGBUILD
+++ b/libre/icecat/PKGBUILD
@@ -32,7 +32,8 @@
# or include code for anti-features; but those will be filtered-out subsequently.
# Any code which implements an anti-feature should be commented-out;
# and include an 'anti-feature' comment, for clarity.
-# Any blacklisted dependencies and non-free sources should be filtered.
+# Any blacklisted dependencies and non-free sources should be filtered,
+# and include a 'non-free' comment, for clarity.
# Without those over-rides, the resulting program may not be FSDG-fit.
# Do not circumvent those over-rides, if compiling for the Parabola repos.
@@ -156,7 +157,7 @@ _check_patching() {
## business ##
prepare() {
- mkdir -p mozbuild
+ mkdir mozbuild
cd "$srcdir/$pkgname-${pkgver%%_*}"
@@ -232,7 +233,7 @@ END
case ${CARCH} in
aarch64|armv7h)
- # version-specific parabola hacks
+ # version-specific hacks
cat >> ../mozconfig <<EOF
export CC=gcc
export CXX=g++
@@ -272,7 +273,6 @@ EOF
# archarm `export` commands are under the '[ARCH-SPECIFIC BUILD ENV]' section
- echo "applying build-arm-libopus.patch"
patch -p1 -i ../build-arm-libopus.patch
# At this point in the script, the arch, arch32, and parabola PKGBUILDs
@@ -295,6 +295,9 @@ ac_add_options --disable-linker=lld
ac_add_options --enable-linker=bfd
ac_add_options --disable-lto
ac_add_options --disable-rust-simd
+ac_add_options --enable-strip
+ac_add_options --disable-debug
+ac_add_options --disable-debug-symbols
export CC=gcc
export CXX=g++
export AR=gcc-ar