summaryrefslogtreecommitdiff
path: root/libre/icecat/PKGBUILD
diff options
context:
space:
mode:
authorMárcio Alexandre Silva Delgado <coadde@adinet.com.uy>2012-06-16 23:29:02 -0300
committerMárcio Alexandre Silva Delgado <coadde@adinet.com.uy>2012-06-16 23:29:02 -0300
commitf6945c0ef1d0abe1b40d5702a9b9edab11063c1c (patch)
treed92132855b48bbcedd94f5da58964b58139dd426 /libre/icecat/PKGBUILD
parent3144d9e25d8bb05e2c1ff69daa51a457d792f068 (diff)
icecat-12.0-1: update package
Diffstat (limited to 'libre/icecat/PKGBUILD')
-rw-r--r--libre/icecat/PKGBUILD67
1 files changed, 46 insertions, 21 deletions
diff --git a/libre/icecat/PKGBUILD b/libre/icecat/PKGBUILD
index 79274ce21..ebd5a1350 100644
--- a/libre/icecat/PKGBUILD
+++ b/libre/icecat/PKGBUILD
@@ -4,6 +4,7 @@
# Contributor (Parabola): fauno <fauno@kiwwwi.com.ar>
# Contributor (Parabola): vando <facundo@esdebian.org>
# Contributor (Parabola): emulatorman <andre.paulista@adinet.com.uy>
+# Contributor (Parabola): Márcio Silva <coadde@adinet.com.uy>
# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
# Thank you very much to the older contributors:
# Contributor: evr <evanroman at gmail>
@@ -15,7 +16,7 @@
_pgo=false
_pkgname=icecat
-pkgver=10.0
+pkgver=12.0
pkgrel=1
if [ -z "$pkgname" ]; then pkgname=$_pkgname; fi
@@ -47,13 +48,15 @@ depends=(
makedepends=(
'autoconf2.13'
'diffutils'
+ 'imagemagick'
'libidl2'
+ 'librsvg'
+ 'libxslt'
'mesa'
'pkg-config'
'python2'
'unzip'
'wireless_tools'
- 'yasm'
'zip'
)
if $_pgo; then
@@ -66,12 +69,26 @@ install=icecat.install
source=(ftp://ftp.gnu.org/gnu/gnuzilla/${pkgver}/${pkgname}-${pkgver}.tar.xz
mozconfig
mozconfig.pgo
+ xulrunner-copy-stub.patch
+ libre.patch
icecat.desktop
icecat-safe.desktop
- libre.patch
- firefox-install-dir.patch
+ icecat-install-dir.patch
vendor.js
- libvpx.patch)
+ gcc47.patch
+ cairo.patch)
+
+md5sums=('04a5504c5c473354bcd20f7116360fee'
+ '3117865902d1a20ab61d75707be9888e'
+ 'ac29b01c189f20abae2f3eef1618ffc0'
+ '683c4540ab84c220937feb7d1a1450ee'
+ 'd403b0ae09306fef3870132e7fd33ed2'
+ 'e81ad01dbc16ba28bf92ba4b7c309ca7'
+ 'd93fe402b87cd000a869e1fd6badc6c9'
+ '268e65c8fcae6152e156c09760a18dfd'
+ '0d053487907de4376d67d8f499c5502b'
+ '79e471e0bd03b1d4e84fd3a6776bd619'
+ '721c59ffc14f14cb0d3a90b7e84df70e')
if [ "$_pkgname" != "$pkgname" ]; then
provides+=("$_pkgname")
@@ -79,13 +96,18 @@ if [ "$_pkgname" != "$pkgname" ]; then
fi
build() {
+ export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$_pkgname"
+ export PYTHON="/usr/bin/python2"
mv "$_pkgname-$pkgver" "$srcdir/mozilla-build"
cd "$srcdir/mozilla-build"
- cp "$srcdir/mozconfig" .mozconfig # Load our build config, disable SafeSearch
- patch -Np1 -i "$srcdir/firefox-install-dir.patch" # install to /usr/lib/$pkgname
+ patch -Np1 -i "$srcdir/icecat-install-dir.patch" # install to /usr/lib/$pkgname
+ patch -Np1 -i "$srcdir/xulrunner-copy-stub.patch" # small fix
patch -Np1 -i "$srcdir/libre.patch" # Remove Google+Mozilla stuff
- patch -Np1 -i "$srcdir/libvpx.patch" # patch from Arch
+ patch -Np1 -i "$srcdir/gcc47.patch"
+ patch -Np1 -i "$srcdir/cairo.patch"
+
+ cp "$srcdir/mozconfig" .mozconfig # Load our build config, disable SafeSearch
if $_pgo; then
cat "$srcdir/mozconfig.pgo" >> .mozconfig
@@ -95,8 +117,21 @@ build() {
sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \
browser/base/Makefile.in
- export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$_pkgname"
- export PYTHON="/usr/bin/python2"
+ # This is a bug, we should fix it.
+ if [ "$CARCH" = "mips64el" ]; then
+ # Fix MIPS N32 support.
+ sed -i 's/defined(_ABIO32)/(defined(_ABIO32) || defined(_ABIN32))/' \
+ js/src/assembler/wtf/Platform.h
+ # Disable JIT.
+ sed -ri 's/#define ENABLE_(JIT|ASSEMBLER) 1/#define ENABLE_\1 0/' \
+ js/src/assembler/wtf/Platform.h
+ sed -ri 's/ENABLE_(JIT|ASSEMBLER)=1/ENABLE_\1=0/' js/src/Makefile.in
+ echo 'ac_add_options --disable-methodjit' >> .mozconfig
+ echo 'ac_add_options --disable-tracejit' >> .mozconfig
+ echo 'ac_add_options --disable-jemalloc' >> .mozconfig
+ fi
+
+ chmod +x build/unix/run-icecat.sh # fix bug for bad file permition
if $_pgo; then
LD_PRELOAD="" /usr/bin/Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 :99 &
@@ -133,18 +168,8 @@ package() {
rm -rf "$pkgdir"/usr/{include,lib/$_pkgname-devel,share/idl}
# Fix a bug with https-everywhere (duplicate rules)
- rm -f "$pkgdir/usr/lib/$pkgname/extensions/https-everywhere@eff.org/chrome/content/rules/GoogleMaps.xml~HEAD"
+ #rm -f "$pkgdir/usr/lib/$pkgname/extensions/https-everywhere@eff.org/chrome/content/rules/GoogleMaps.xml~HEAD"
# Workaround for now: https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -sf $_pkgname "$pkgdir/usr/lib/$_pkgname/$_pkgname-bin"
}
-
-md5sums=('5a30f5c5422fb7c9b1a2d253028df9d7'
- '6f3a8fd65c416216a1b56b0c2d2d81aa'
- 'ac29b01c189f20abae2f3eef1618ffc0'
- 'e81ad01dbc16ba28bf92ba4b7c309ca7'
- 'd93fe402b87cd000a869e1fd6badc6c9'
- '145f453ef82f643711c10d97ec57a805'
- '1e4bcac59e93d21fffa6a1d1ad235247'
- 'c382e35315047e4ca368d09383b39b8d'
- '5d418ecdbdb9f40597df6b978b0b5ee5')