summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-12-16 00:49:42 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-12-16 00:49:42 -0200
commit5d1eac6bc7b0336a940caf78d09102cf3d2bf4ab (patch)
tree60f944f93428e84d04826586793084f3ec515288 /libre/iceweasel-libre/PKGBUILD
parentbd54db62d1fb950ec14bfac9df0f6efaec2115c9 (diff)
iceweasel-libre-1:26.0.deb1-1: updating version
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD53
1 files changed, 28 insertions, 25 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index 9f3ee6be8..968c3d122 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -14,7 +14,7 @@ _pgo=true
# We're getting this from Debian Experimental
_debname=iceweasel
-_debver=25.0
+_debver=26.0
_debrel=deb1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -23,7 +23,7 @@ _pkgname=iceweasel
pkgname=iceweasel-libre
epoch=1
pkgver=$_debver.$_debrel
-pkgrel=3
+pkgrel=1
pkgdesc="A libre version of Debian Iceweasel, the standalone web browser based on Mozilla Firefox."
arch=(i686 x86_64 mips64el)
@@ -38,9 +38,10 @@ if $_pgo; then
fi
optdepends=('networkmanager: Location detection via available WiFi networks'
'gstreamer0.10-base-plugins: vorbis decoding, ogg demuxing'
- 'gstreamer0.10-bad-libre-plugins: aac, vp8 and opus decoding'
'gstreamer0.10-good-plugins: webm and mp4 demuxing'
- 'gstreamer0.10-ugly-plugins: h.264 decoding'
+ 'gstreamer0.10-bad-libre-plugins: aac, vp8 and opus decoding'
+ 'gstreamer0.10-ugly-plugins: h.264 and mp3 decoding'
+ 'gstreamer0.10-ffmpeg: more decoders'
'libpulse: PulseAudio audio driver')
url="http://packages.debian.org/experimental/${_pkgname}"
install=iceweasel.install
@@ -56,17 +57,19 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
iceweasel-install-dir.patch
vendor.js
iceweasel-20.0.1-fixed-loading-icon.png
- Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch)
-md5sums=('dd1462b582747210cc6c2ac1d01c4c17'
- '4f4cde44b6e83cf78ff5d6e757d1913c'
- '350feec44d359c31679dbec3de6685df'
+ Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
+ Fixup-Reset-Firefox-after-bad-merge.patch)
+md5sums=('219cf21e0642e8a364365286f23d0624'
+ '2001d0477bcefd0eeaab584402133691'
+ '023120a970670dc85cea19393f0b94b6'
'df08eaa1ac3bc6c2356be4fbf8ec8932'
- '8c11b80574b11e96c2ef44fa16f4b844'
+ 'aeb2feb0955248e087f2b0cdd73e3e4c'
'7b9e5996dd9fe0b186a43a297db1c6b5'
- 'abf5ecb74caa857abb42bcfbb3442d9c'
+ '6620e724ec9a1be74e65089d81d802f7'
'816013881cfc9a1f4f0ede72b014f8b3'
'6e335a517c68488941340ee1c23f97b0'
- 'ee3279c706c3a69e6f8eda415c4d35b0')
+ 'dbf1c021e5f7ac323197b219bf213c50'
+ '8e165ef85ddd72491f0b48f8954afca6')
prepare() {
export DEBIAN_BUILD="mozilla-release"
@@ -81,12 +84,16 @@ prepare() {
# Doesn't apply and seems unimportant
rm -v debian/patches/l10n/Place-google-and-gmail-before-yandex.patch || true
- # This patch doesn't works in some parts due that has patches for others locales languages, source code hasn't it
+ # Doesn't works in some parts due it has patches for others locales languages, source code hasn't it
rm -v debian/patches/debian-hacks/Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch || true
+ # It needs to be patched after Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
+ rm -v debian/patches/debian-hacks/Fixup-Reset-Firefox-after-bad-merge.patch || true
+
quilt push -av
patch -Np1 -i "$srcdir/Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch" # Adding fixed Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
+ patch -Np1 -i "$srcdir/Fixup-Reset-Firefox-after-bad-merge.patch"
patch -Np1 -i "$srcdir/iceweasel-install-dir.patch" # install to /usr/lib/$_pkgname
# Patch and remove anything that's left
@@ -177,20 +184,16 @@ build() {
fi
if $_pgo; then
- if [[ $CARCH != i686 ]]; then
- # Set up PGO
- export DISPLAY=:99
- Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
-
- if ! make -f client.mk build MOZ_PGO=1; then
- kill $!
- return 1
- fi
-
- kill $! || true
- else
- make -f client.mk build
+ # Set up PGO
+ export DISPLAY=:99
+ Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
+
+ if ! make -f client.mk build MOZ_PGO=1; then
+ kill $!
+ return 1
fi
+
+ kill $! || true
else
make -f client.mk build
fi