summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-30 18:02:21 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-30 18:02:21 -0300
commit64683dd2032ed586532031766409e3335d52dd35 (patch)
tree528f5ae1a1c710ac82cc1cccd19784c6fdec2c4f /libre/iceweasel-libre/PKGBUILD
parentc93a353e8be76103677541af962f74a3b7c93fd9 (diff)
iceweasel-libre-1:29.0.deb1-1: updating version
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index 1fafebea5..57da4aba7 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -14,7 +14,7 @@ _pgo=true
# We're getting this from Debian Experimental
_debname=iceweasel
-_debver=28.0
+_debver=29.0
_debrel=deb1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -28,7 +28,7 @@ pkgrel=1
pkgdesc="A libre version of Debian Iceweasel, the standalone web browser based on Mozilla Firefox."
arch=(i686 x86_64 mips64el)
license=(MPL GPL LGPL)
-depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hicolor-icon-theme hunspell libevent libnotify libvpx libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification)
+depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hicolor-icon-theme hunspell icu libevent libnotify libvpx libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification)
makedepends=(autoconf2.13 diffutils gstreamer0.10-base imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa pkg-config python2 quilt unzip zip)
[ "$CARCH" != "mips64el" ] && makedepends+=('yasm')
options=(!emptydirs !makeflags)
@@ -60,17 +60,17 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
iceweasel-20.0.1-fixed-loading-icon.png
Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
Fixup-Reset-Firefox-after-bad-merge.patch)
-md5sums=('8b53f3d7c1eea0338408f743f619eec1'
- 'e5399fd8ea49c227b9a4c45997dc7111'
- '023120a970670dc85cea19393f0b94b6'
+md5sums=('2cc40f481ca7b8421925a1def5fe14a0'
+ '7f00f6a076c6a92db162e18d8e9e92a5'
+ '92a08a18995b915d6a6d0dab93ec6c1d'
'df08eaa1ac3bc6c2356be4fbf8ec8932'
'5d22063ebea2472dd0b1163b32b2050b'
'b03a979a78484503ba8dddad4f2c96d1'
'7b9e5996dd9fe0b186a43a297db1c6b5'
- '6620e724ec9a1be74e65089d81d802f7'
+ '1c42509891cf6843660a5f3c69896e80'
'816013881cfc9a1f4f0ede72b014f8b3'
'6e335a517c68488941340ee1c23f97b0'
- '032553b17a61a9a79c7a03c8967251b2'
+ '9d1cc7b80085a4438305e9e37d42745b'
'8e165ef85ddd72491f0b48f8954afca6')
prepare() {
@@ -206,7 +206,7 @@ package() {
export DEBIAN_BUILD="mozilla-release"
cd "$srcdir/$DEBIAN_BUILD"
- make -f client.mk DESTDIR="$pkgdir" install
+ make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
install -Dm644 ../vendor.js "$pkgdir/usr/lib/$_pkgname/browser/defaults/preferences/vendor.js"
@@ -231,9 +231,6 @@ package() {
ln -sf /usr/lib/mozilla/plugins "$pkgdir/usr/lib/$_pkgname/browser/plugins"
ln -sf /usr/lib/mozilla/searchplugins "$pkgdir/usr/lib/$_pkgname/browser/searchplugins"
- # We don't want the development stuff
- rm -rf "$pkgdir"/usr/{include,lib/$_pkgname-devel,share/idl}
-
# Workaround for now: https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -sf $_pkgname "$pkgdir/usr/lib/$_pkgname/$_pkgname-bin"
}