summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-05-15 09:02:59 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-05-15 09:02:59 -0300
commit6a23f1145fffe7aa343a27beef12dbaf91279a9f (patch)
tree4b78bcdced9bb58f720d591ca774b5bd02662367 /libre/iceweasel-libre/PKGBUILD
parent833f4e0de04122bc2ebb3727909557b4c08582a9 (diff)
iceweasel-libre-1:29.0.1.deb1-2: build with clang as temporary workaround for FS#40331 => https://bugs.archlinux.org/task/40331
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index e8fbdc228..43c166210 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -23,13 +23,13 @@ _pkgname=iceweasel
pkgname=iceweasel-libre
epoch=1
pkgver=$_debver.$_debrel
-pkgrel=1
+pkgrel=2
pkgdesc="A libre version of Debian Iceweasel, the standalone web browser based on Mozilla Firefox."
arch=(i686 x86_64 mips64el)
license=(MPL GPL LGPL)
depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hicolor-icon-theme hunspell icu libevent libnotify libvpx libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification)
-makedepends=(autoconf2.13 diffutils gstreamer0.10-base imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa pkg-config python2 quilt unzip zip)
+makedepends=(autoconf2.13 clang diffutils gstreamer0.10-base imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa pkg-config python2 quilt unzip zip)
[ "$CARCH" != "mips64el" ] && makedepends+=('yasm')
options=(!emptydirs !makeflags)
if $_pgo; then
@@ -186,6 +186,8 @@ build() {
export PATH="$srcdir/path:$PATH"
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$_pkgname"
export PYTHON="/usr/bin/python2"
+ export CC=clang
+ export CXX=clang++
if [[ $CARCH == i686 ]]; then
# Work around memory address space exhaustion during linking on i686