summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-02-15 04:42:38 -0200
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-02-15 04:42:38 -0200
commit90f20e411db4f4e79cbb5d7b39909cac3a382662 (patch)
treea63616519b6fdf0d790d5c6727a1e92b1b4551b0 /libre/iceweasel-libre/PKGBUILD
parent0ce8cbcd69b1b054e2b4f9d4718b748e2440b9e5 (diff)
fixing icedove-libre
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD30
1 files changed, 11 insertions, 19 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index 5c6313e9e..f9b1dbd8e 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
-# Contributor (Parabola): Márcio Silva <coadde@parabola.nu>
+# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
# Contributor (ConnochaetOS): Henry Jensen <hjensen@connochaetos.org>
# Contributor (Parabola): Luke Shumaker <lukeshu@sbcglobal.net>
+# Contributor: Figue <ffigue at gmail>
# Contributor (Parabola): fauno <fauno@kiwwwi.com.ar>
# Contributor (Parabola): vando <facundo@esdebian.org>
# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
-# Contributor: Figue <ffigue at gmail>
# Thank you very much to the older contributors:
# Contributor: evr <evanroman at gmail>
# Contributor: Muhammad 'MJ' Jassim <UnbreakableMJ@gmail.com>
-_pgo=true
+_pgo=false
# We're getting this from Debian Experimental
_debname=iceweasel
-_debver=27.0
-_debrel=deb2
+_debver=26.0
+_debrel=deb1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -39,7 +39,7 @@ fi
optdepends=('networkmanager: Location detection via available WiFi networks'
'gstreamer0.10-base-plugins: vorbis decoding, ogg demuxing'
'gstreamer0.10-good-plugins: webm and mp4 demuxing'
- 'gstreamer0.10-bad-plugins: aac, vp8 and opus decoding'
+ 'gstreamer0.10-bad-libre-plugins: aac, vp8 and opus decoding'
'gstreamer0.10-ugly-plugins: h.264 and mp3 decoding'
'gstreamer0.10-ffmpeg: more decoders'
'libpulse: PulseAudio audio driver')
@@ -49,28 +49,26 @@ replaces=('firefox')
conflicts=('firefox')
provides=('firefox')
source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
- "$_debrepo/`debfile $_debname`_$_debver-${_debrel#deb}.debian.tar.xz"
+ "$_debrepo/`debfile $_debname`_$_debver-${_debrel#deb}.debian.tar.gz"
mozconfig
mozconfig.pgo
libre.patch
- gnu_headshadow.png
iceweasel.desktop
iceweasel-install-dir.patch
vendor.js
iceweasel-20.0.1-fixed-loading-icon.png
Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
Fixup-Reset-Firefox-after-bad-merge.patch)
-md5sums=('0baf0b166421f785db79bd33fe7b0748'
- '2446de5f7844caae8cd7e46b3b72119c'
+md5sums=('219cf21e0642e8a364365286f23d0624'
+ '2001d0477bcefd0eeaab584402133691'
'023120a970670dc85cea19393f0b94b6'
'df08eaa1ac3bc6c2356be4fbf8ec8932'
- '641e8b54a684161c60209b81f260a19b'
- 'b03a979a78484503ba8dddad4f2c96d1'
+ '5f9fe968db02dead66315248fdd01a5e'
'7b9e5996dd9fe0b186a43a297db1c6b5'
'6620e724ec9a1be74e65089d81d802f7'
'816013881cfc9a1f4f0ede72b014f8b3'
'6e335a517c68488941340ee1c23f97b0'
- '3dcb1f1eccce5b6b90fa48ab94bf7a47'
+ 'dbf1c021e5f7ac323197b219bf213c50'
'8e165ef85ddd72491f0b48f8954afca6')
prepare() {
@@ -94,8 +92,6 @@ prepare() {
quilt push -av
- install -m644 "$srcdir/gnu_headshadow.png" browser/base/content/abouthome # Put gnu_headshadow.png on the source code
-
patch -Np1 -i "$srcdir/Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch" # Adding fixed Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
patch -Np1 -i "$srcdir/Fixup-Reset-Firefox-after-bad-merge.patch"
patch -Np1 -i "$srcdir/iceweasel-install-dir.patch" # install to /usr/lib/$_pkgname
@@ -171,10 +167,6 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=841734
cp "$srcdir/iceweasel-20.0.1-fixed-loading-icon.png" \
browser/themes/linux/tabbrowser/loading.png
-
- # Remove non-existent file on Makefile.in
- sed -i '\|build/pgo/blueprint/valid.png|d' build/Makefile.in
-
}
build() {