summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-06-12 01:44:59 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-06-12 01:44:59 -0300
commitda19b3a585db23bc37d0554f0226279a1d06b827 (patch)
treee8cb1f1760ca0822a2db207eff9a89026cf57dc1 /libre/iceweasel-libre/PKGBUILD
parent721160f8acc254448e3c9cc6b533ec2e183867d6 (diff)
iceweasel-libre-1:30.0.deb1-1: updating version
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD41
1 files changed, 12 insertions, 29 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index 083262b48..0a4127d60 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -14,8 +14,8 @@ _pgo=true
# We're getting this from Debian Sid
_debname=iceweasel
-_debver=29.0.1
-_debrel=deb2
+_debver=30.0
+_debrel=deb1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -29,19 +29,16 @@ pkgdesc="A libre version of Debian Iceweasel, the standalone web browser based o
arch=(i686 x86_64 mips64el)
license=(MPL GPL LGPL)
depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hicolor-icon-theme hunspell icu libevent libnotify libvpx libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification)
-makedepends=(autoconf2.13 clang diffutils gstreamer0.10-base imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa pkg-config python2 quilt unzip zip)
+makedepends=(autoconf2.13 diffutils gst-plugins-base-libs imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa pkg-config python2 quilt unzip zip)
[ "$CARCH" != "mips64el" ] && makedepends+=('yasm')
-options=(!emptydirs !makeflags)
+options=(!emptydirs !makeflags debug)
if $_pgo; then
makedepends+=(xorg-server-xvfb)
options+=(!ccache)
fi
optdepends=('networkmanager: Location detection via available WiFi networks'
- 'gstreamer0.10-base-plugins: vorbis decoding, ogg demuxing'
- 'gstreamer0.10-good-plugins: webm and mp4 demuxing'
- 'gstreamer0.10-bad-plugins: aac, vp8 and opus decoding'
- 'gstreamer0.10-ugly-plugins: h.264 and mp3 decoding'
- 'gstreamer0.10-ffmpeg: more decoders'
+ 'gst-plugins-good: h.264 video'
+ 'gst-libav: h.264 video'
'libpulse: PulseAudio audio driver')
url="http://packages.debian.org/sid/${_pkgname}"
install=iceweasel.install
@@ -57,21 +54,17 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
iceweasel.desktop
iceweasel-install-dir.patch
vendor.js
- iceweasel-20.0.1-fixed-loading-icon.png
- Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
- Fixup-Reset-Firefox-after-bad-merge.patch)
-md5sums=('4db358c753cb15a526dfe79c6602c886'
- '4d786ae63da53ba6da8105fbb50cbad9'
- '92a08a18995b915d6a6d0dab93ec6c1d'
+ iceweasel-20.0.1-fixed-loading-icon.png)
+md5sums=('3a603dbbfc9c7e56a8e58cede90a9b0b'
+ '89e7b2ed2e84fdefcc1eca7d076b72c2'
+ '2f5cb3df42b09fbfeaee5e72e5433ab9'
'df08eaa1ac3bc6c2356be4fbf8ec8932'
- '5d22063ebea2472dd0b1163b32b2050b'
+ '21d3ffb77ea84ce897016bc713b52ef4'
'b03a979a78484503ba8dddad4f2c96d1'
'7b9e5996dd9fe0b186a43a297db1c6b5'
'1c42509891cf6843660a5f3c69896e80'
'783a5927246f014855b96a3abb92566b'
- '6e335a517c68488941340ee1c23f97b0'
- '9d1cc7b80085a4438305e9e37d42745b'
- '8e165ef85ddd72491f0b48f8954afca6')
+ '6e335a517c68488941340ee1c23f97b0')
prepare() {
export DEBIAN_BUILD="mozilla-release"
@@ -86,18 +79,10 @@ prepare() {
# Doesn't apply and seems unimportant
rm -v debian/patches/l10n/Place-google-and-gmail-before-yandex.patch || true
- # Doesn't works in some parts due it has patches for others locales languages, source code hasn't it
- rm -v debian/patches/debian-hacks/Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch || true
-
- # It needs to be patched after Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
- rm -v debian/patches/debian-hacks/Fixup-Reset-Firefox-after-bad-merge.patch || true
-
quilt push -av
install -m644 "$srcdir/gnu_headshadow.png" browser/base/content/abouthome # Put gnu_headshadow.png on the source code
- patch -Np1 -i "$srcdir/Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch" # Adding fixed Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
- patch -Np1 -i "$srcdir/Fixup-Reset-Firefox-after-bad-merge.patch"
patch -Np1 -i "$srcdir/iceweasel-install-dir.patch" # install to /usr/lib/$_pkgname
# Patch and remove anything that's left
@@ -186,8 +171,6 @@ build() {
export PATH="$srcdir/path:$PATH"
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$_pkgname"
export PYTHON="/usr/bin/python2"
- export CC=clang
- export CXX=clang++
if [[ $CARCH == i686 ]]; then
# Work around memory address space exhaustion during linking on i686