summaryrefslogtreecommitdiff
path: root/libre/iceweasel-ublock-origin/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-09-22 08:51:32 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-09-22 08:51:32 -0300
commitbebf778aebed6092387cad2383045cd6fdb1c889 (patch)
treee63f120203e07a79da08ad2be3edfc3765686c65 /libre/iceweasel-ublock-origin/PKGBUILD
parent49641e30f93ed8394a72e0f2915823b322ce72a0 (diff)
ice{cat,weasel}-ublock-origin-1.9.6-1: updating version
Diffstat (limited to 'libre/iceweasel-ublock-origin/PKGBUILD')
-rw-r--r--libre/iceweasel-ublock-origin/PKGBUILD30
1 files changed, 13 insertions, 17 deletions
diff --git a/libre/iceweasel-ublock-origin/PKGBUILD b/libre/iceweasel-ublock-origin/PKGBUILD
index 7789ff7e5..0811816e9 100644
--- a/libre/iceweasel-ublock-origin/PKGBUILD
+++ b/libre/iceweasel-ublock-origin/PKGBUILD
@@ -1,28 +1,24 @@
+# Maintainer (Arch): Daniel M. Capella <polyzen@archlinux.info>
# Maintainer: André Silva <emulatorman@parabola.nu>
pkgname=iceweasel-ublock-origin
-pkgver=1.6.8
+pkgver=1.9.6
pkgrel=1
-pkgdesc="Extension fork of the Adblock Plus for Iceweasel which block ads and banners, but without 'acceptable ads' feature"
+pkgdesc='An efficient blocker add-on for various browsers. Fast, potent, and lean.'
+url=https://github.com/gorhill/uBlock
arch=('any')
-url="https://github.com/gorhill/uBlock"
license=('GPL3')
-groups=('iceweasel-addons')
-depends=("iceweasel")
-makedepends=('unzip')
+depends=('iceweasel')
provides=('iceweasel-adblock-plus')
conflicts=('iceweasel-adblock-plus')
-replaces=('firefox-adblock-plus' 'iceweasel-adblock-plus')
-source=("ublock-origin-$pkgver.xpi::https://github.com/gorhill/uBlock/releases/download/$pkgver/uBlock0.firefox.xpi")
-md5sums=('45ba423404d7a09bc4eff5ea88591b5a')
+replaces=('firefox-ublock-origin' 'firefox-adblock-plus' 'iceweasel-adblock-plus')
+groups=('iceweasel-addons')
+source=("https://addons.cdn.mozilla.net/user-media/addons/607454/ublock_origin-$pkgver-fx+sm+an+tb.xpi")
+noextract=("${source##*/}")
+sha256sums=('32157544fdaf078651fdae209f12a58e82a55ded9067d89023136c63100f7adc')
package() {
- # extension
- _dest="$pkgdir/usr/lib/iceweasel/browser/extensions/uBlock0@raymondhill.net"
- find . -type d -exec install -d {} $_dest/{} \;
- find . -type f -exec install -Dm644 {} $_dest/{} \;
-
- # license
- install -Dm644 LICENSE.txt \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "${source##*/}" "$pkgdir"/usr/lib/iceweasel/browser/extensions/uBlock0@raymondhill.net.xpi
}
+
+# vim:set ts=2 sw=2 et: