summaryrefslogtreecommitdiff
path: root/libre/iceweasel-ublock-origin/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-10-04 18:56:27 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-10-04 18:56:27 -0300
commitd35188e4ff943883232f9e0266d2f1ed132f07c2 (patch)
tree7051146351eb30ceeea4e7bf2be3d0607749e1c0 /libre/iceweasel-ublock-origin/PKGBUILD
parent0e943a9183aa674aaca3df1ead6ea9dbe083b933 (diff)
ice{cat,weasel}-ublock-origin: add new packages to [libre] to replace ice{cat,weasel}-adblock-plus packages
Diffstat (limited to 'libre/iceweasel-ublock-origin/PKGBUILD')
-rw-r--r--libre/iceweasel-ublock-origin/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/libre/iceweasel-ublock-origin/PKGBUILD b/libre/iceweasel-ublock-origin/PKGBUILD
new file mode 100644
index 000000000..16d69bc39
--- /dev/null
+++ b/libre/iceweasel-ublock-origin/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+pkgname=iceweasel-ublock-origin
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Extension fork of the Adblock Plus for Iceweasel which block ads and banners, but without 'acceptable ads' feature"
+arch=('any')
+url="https://github.com/gorhill/uBlock"
+license=('GPL3')
+groups=('iceweasel-addons')
+depends=("iceweasel")
+makedepends=('unzip')
+provides=('iceweasel-adblock-plus')
+conflicts=('iceweasel-adblock-plus')
+replaces=('firefox-adblock-plus' 'iceweasel-adblock-plus')
+source=("https://github.com/gorhill/uBlock/releases/download/$pkgver/uBlock0.firefox.xpi")
+md5sums=('9f907a1d2e845cd34acfb5a669c013ac')
+
+package() {
+ # extension
+ _dest="$pkgdir/usr/lib/iceweasel/browser/extensions/uBlock0@raymondhill.net"
+ find . -type d -exec install -d {} $_dest/{} \;
+ find . -type f -exec install -Dm644 {} $_dest/{} \;
+
+ # license
+ install -Dm644 LICENSE.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}