summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2023-02-15 17:09:07 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2023-02-17 16:51:10 -0500
commit12475eed2b49599c5715860d79f7f62b82b1689d (patch)
tree2a3be5468caea483e28b04e4b6d2dbe7b2564d02 /libre/iceweasel/PKGBUILD
parentc1011881f760cac975044b21c7fe24ead26f0558 (diff)
[icecat][icewesel]: minimize diffs across PKGBUILDs
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 5179d24c9..5a7c5efe4 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -412,8 +412,8 @@ ac_add_options --with-wasi-sysroot=/usr/share/wasi-sysroot
# Branding
ac_add_options --disable-official-branding # branding over-ride
ac_add_options --enable-update-channel=release
-ac_add_options --with-distribution-id=nu.parabola # branding over-ride
ac_add_options --with-branding=browser/branding/${pkgname} # branding over-ride
+ac_add_options --with-distribution-id=nu.parabola # branding over-ride
ac_add_options --with-app-name=${pkgname} # branding over-ride
ac_add_options --with-app-basename=${pkgname} # branding over-ride
ac_add_options --with-unsigned-addon-scopes=app,system
@@ -463,15 +463,6 @@ EOF
# archarm configuration #
- # archarm has these differences in ## general configuration ## above
- sed -i '
- /--enable-hardening/d
- /--enable-optimize/d
- /--enable-rust-simd/d
- s| --with-wasi-sysroot=.*| --without-wasm-sandboxed-libraries|
- /--disable-eme/d
- ' ../mozconfig
-
if [[ $CARCH == "armv7h" ]]; then
echo "ac_add_options --disable-elf-hack" >> .mozconfig
# https://bugzilla.redhat.com/show_bug.cgi?id=1641623
@@ -495,12 +486,24 @@ EOF
# archarm patching is under the 'technical patching' section
- # At this point in the script, the arch, arch32, and parabola PKGBUILDs
- # have prepared a temporary ${srcdir}/mozconfig; but the archarm PKGBUILD
+ # archarm has these differences in ## general configuration ## above
+ # NOTE: '--disable-eme' is currently an invalid option for armv7h.
+ # It must be deleted in order to compile.
+ # If ever it becomes valid, it should not be deleted below.
+ sed -i '
+ /--enable-hardening/d
+ /--enable-optimize/d
+ /--enable-rust-simd/d
+ s| --with-wasi-sysroot=.*| --without-wasm-sandboxed-libraries|
+ /--disable-eme/d
+ ' ../mozconfig
+
+ # At this point in the recipe (this `case` block), the arch, arch32, and parabola
+ # PKGBUILDs have prepared a temporary ${srcdir}/mozconfig; but the archarm PKGBUILD
# writes directly to the final firefox-$pkgver/.mozconfig.
# We allowed .mozconfig to be written above, only to minimize the diff against archarm.
- # For consistency across arches, we move it to ${srcdir}/mozconfig now.
- # ${srcdir}/mozconfig will clobber firefox-$pkgver/.mozconfig later, in build().
+ # For consistency across arches, we append those changes to ${srcdir}/mozconfig now.
+ # ${srcdir}/mozconfig will clobber firefox-$pkgver/.mozconfig later, during build().
cat .mozconfig >> ../mozconfig
;;
i686)
@@ -694,6 +697,7 @@ END
rm -v toolkit/crashreporter/tools/upload_symbols.py
rm -frv third_party/rust/winapi-{i686,x86_64}-pc-windows-gnu/**/*.a
+
## patching sanity checks ##
_check_patching
}
@@ -732,8 +736,6 @@ build() {
export LDFLAGS+=" -Wl,--no-keep-memory " # -Wl,--reduce-memory-overheads -Wl,--max-cache-size=16384000 "
export MOZ_SOURCE_CHANGESET="DEVEDITION_${pkgver//./_}_RELEASE"
-# export MOZ_MAKE_FLAGS=-j2
-
# libvpx has some hard-coded compiler flags for MMX, SSE, SSE2, use the correct one
# per CARCH (75.0 uses an intrisic _mm_empty now, which required the corresponding
# architecture flag to be preset - before it was merely embedding some assembly