summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2018-08-16 01:25:57 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2018-08-16 01:40:57 -0400
commit48bdff3caf252cc4346269ae282776d7f5b70e5e (patch)
tree8a4d62f4c198aa777d76b5e1f892dc334393378b /libre/iceweasel/PKGBUILD
parentfc94e705d9b8f7df0938fae403c36da9db5956ea (diff)
iceweasel upgrade to 61.0.2 (buggy - fix #1941)
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index d7b9fed4f..12afc0d41 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id$
# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
@@ -28,9 +27,9 @@
_pkgname=firefox
pkgname=iceweasel
epoch=1
-pkgver=59.0.2
-pkgrel=4
-_bver=59.0
+pkgver=61.0.2
+pkgrel=1
+_bver=61.0
_brel=1
pkgdesc="Libre standalone web browser based on Mozilla Firefox"
arch=(x86_64)
@@ -38,10 +37,10 @@ arch+=(i686 armv7h)
license=(MPL GPL LGPL)
url="https://wiki.parabola.nu/$pkgname"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
- nss hunspell sqlite ttf-font libpulse libvpx icu)
+ nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
depends+=('icu>=62' 'icu<63')
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
- autoconf2.13 rust mercurial clang llvm jack gtk2)
+ autoconf2.13 rust mercurial clang llvm jack gtk2 python)
makedepends+=(mozilla-searchplugins quilt libxslt imagemagick)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
@@ -60,9 +59,9 @@ source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_$_bver-$_brel.brand
sha256sums=('5b7382ac0697e2abce5e2873878069a47fff5f3a5eeec4c3a0186598a1592833'
'ed350ef2f528b999a621f7080fa80948be6b351e67ce32529fb32bcf47bb21fa'
'02000d185e647aa20ca336e595b4004bb29cdae9d8f317f90078bdcc7a36e873'
- '7ee098251254cbfbcdf78463d3af95089e38d7942a5c7936dacbcf0c5fb1c5b8'
+ 'dabd5a0b8023e8ca13f6ae5fcb9e6c29531fc952bc781b4aa25c8a598187768e'
'SKIP'
- 'ec074da734d847dbd1b93e980304d0a26a2c07232b388322c81235a0e5856887')
+ 'f2f3484a5339c7208a2a44b63a185ec5a57f837040627d29cc45b4d1d14ef6c2')
validpgpkeys=('BFA8008A8265677063B11BF47171986E4B745536') # Andreas Grapentin
prepare() {
@@ -79,9 +78,9 @@ ac_add_options --enable-application=browser
ac_add_options --prefix=/usr
ac_add_options --enable-release
-ac_add_options --enable-gold
-ac_add_options --enable-pie
-ac_add_options --enable-optimize="-O2"
+ac_add_options --enable-linker=gold
+ac_add_options --enable-hardening
+ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
# Branding
@@ -161,7 +160,8 @@ END
\|installLinux| s|true|false|
' browser/base/content/browser-plugins.js
- # replace newtab page with abouthome
+ # re-use 'abouthome' page for 'newtab' page
+ install -d browser/base/content/newtab
cat browser/base/content/abouthome/aboutHome.xhtml > browser/base/content/newtab/newTab.xhtml
# Load our searchplugins
@@ -202,6 +202,9 @@ package() {
// Use LANG environment variable to choose locale
pref("intl.locale.requested", "");
+// Use system-provided dictionaries
+pref("spellchecker.dictionary_path", "/usr/share/hunspell");
+
// Disable default browser checking.
pref("browser.shell.checkDefaultBrowser", false);