summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-03-16 09:24:21 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-03-16 09:26:12 +0100
commit95b66a84882efd434133fe9995482536146ac071 (patch)
treecb87f05eb6f8bb5e546c15471709550f43eee79a /libre/iceweasel/PKGBUILD
parentc19ff1fd47adef6a1171673b4789c7e6d6f3798c (diff)
libre/iceweasel: updated to 59.0
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD74
1 files changed, 43 insertions, 31 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index e26a8d986..fbf8b4e18 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -20,28 +20,28 @@
# parabola changes and rationale:
# - rebranded to iceweasel
-# - changed to release tarball from repo checkout
# - removed google api keys and usage
# - removed use of firefox-symbolic.svg
-# - using tarball instead of repository
# - added makedepends: mozilla-searchplugins, quilt, libxslt, imagemagick
-# - added replaces, conflicts and provides: firefox
+# - added replaces, conflicts: firefox
_pkgname=firefox
pkgname=iceweasel
epoch=1
-pkgver=58.0.2
-pkgrel=1
-_bver=58.0
+pkgver=59.0
+pkgrel=2
+_bver=59.0
_brel=1
pkgdesc="Libre standalone web browser based on Mozilla Firefox"
-arch=(x86_64 i686 armv7h)
+arch=(x86_64)
+arch+=(i686 armv7h)
license=(MPL GPL LGPL)
url="https://wiki.parabola.nu/$pkgname"
-depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
nss hunspell sqlite ttf-font libpulse libvpx icu)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
- autoconf2.13 rust mercurial clang llvm jack mozilla-searchplugins quilt libxslt imagemagick)
+ autoconf2.13 rust mercurial clang llvm jack gtk2)
+makedepends+=(mozilla-searchplugins quilt libxslt imagemagick)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -49,31 +49,26 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
options=(!emptydirs !makeflags !strip)
replaces=("$_pkgname")
conflicts=("$_pkgname")
-source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
+# https://archive.mozilla.org/pub/firefox/releases/$pkgver/SOURCE
+_commit=c61f5f5ead48c78a80c80db5c489bdc7cfaf8175
+source=(firefox-$pkgver.tar.bz::https://hg.mozilla.org/releases/mozilla-release/archive/$_commit.tar.bz2
$pkgname.desktop
- 0001-Bug-1430274-Define-MOZ_ALSA-for-more-source-files.-r.patch
- $pkgname-install-dir.patch no-crmf.diff
- https://repo.parabola.nu/other/iceweasel/${pkgname}_$_bver-$_brel.branding.tar.xz{,.sig}
- libre.patch)
-sha256sums=('2b7794e4c2a24fa388f3acb2956c96bb2c3eae455467f0e386788ebaea7240c3'
+ no-crmf.diff)
+source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_$_bver-$_brel.branding.tar.xz{,.sig}
+ libre.patch)
+sha256sums=('fb5ff29e2bc68fa5ebb8bd8c800b597fcb2dd5820899aef3372380c99a0acec6'
'ed350ef2f528b999a621f7080fa80948be6b351e67ce32529fb32bcf47bb21fa'
- 'e8a695bd6a007525390c502739c0f00d5d753a1bde7053c21c712075f2c2994d'
- 'a94f80abe65608cd49054a30acc31e4d0885fe5b2a38cf08ded5e5b51b87c99d'
- 'fb85a538044c15471c12cf561d6aa74570f8de7b054a7063ef88ee1bdfc1ccbb'
- '482cfe2d92f0b9638061eaf1b457abe0a8c8a0521bd67767e5c5010868612d25'
+ '02000d185e647aa20ca336e595b4004bb29cdae9d8f317f90078bdcc7a36e873'
+ '7ee098251254cbfbcdf78463d3af95089e38d7942a5c7936dacbcf0c5fb1c5b8'
'SKIP'
- '12170e0539997396f83c511317377cf4cc5af74177c6c1db14275ebf0b932bb9')
+ 'ec074da734d847dbd1b93e980304d0a26a2c07232b388322c81235a0e5856887')
validpgpkeys=('BFA8008A8265677063B11BF47171986E4B745536') # Andreas Grapentin
prepare() {
mkdir path
ln -s /usr/bin/python2 path/python
- cd "$srcdir/$_pkgname-$pkgver"
- patch -Np1 -i ../$pkgname-install-dir.patch
-
- # https://bugs.archlinux.org/task/57285
- patch -Np1 -i ../0001-Bug-1430274-Define-MOZ_ALSA-for-more-source-files.-r.patch
+ cd mozilla-release-$_commit
# https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
patch -Np1 -i ../no-crmf.diff
@@ -147,6 +142,12 @@ END
install -m644 "$brandingdir/branding/watermark.svg" \
browser/extensions/onboarding/content/img
+ # produce icons
+ for i in 128; do
+ rsvg-convert -w $i -h $i "$srcdir/$pkgname-$_bver/branding/${pkgname}_icon.svg" \
+ -o "browser/branding/iceweasel/default$i.png"
+ done
+
# Patch and remove anything that's left
patch -Np1 -i "$srcdir/libre.patch"
sed -i 's|Adobe Flash|SWF Player|g;
@@ -173,12 +174,13 @@ END
}
build() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd mozilla-release-$_commit
# _FORTIFY_SOURCE causes configure failures
CPPFLAGS+=" -O2"
export PATH="$srcdir/path:$PATH"
+ export MOZ_SOURCE_REPO="$_repo"
# Do PGO
#xvfb-run -a -n 95 -s "-extension GLX -screen 0 1280x1024x24" \
@@ -188,7 +190,7 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd mozilla-release-$_commit
DESTDIR="$pkgdir" ./mach install
find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +
@@ -196,7 +198,7 @@ package() {
_vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
install -Dm644 /dev/stdin "$_vendorjs" <<END
// Use LANG environment variable to choose locale
-pref("intl.locale.matchOS", true);
+pref("intl.locale.requested", "");
// Disable default browser checking.
pref("browser.shell.checkDefaultBrowser", false);
@@ -368,8 +370,18 @@ pref("dom.event.clipboardevents.enabled",false);
pref("network.prefetch-next", false);
pref("network.dns.disablePrefetch", true);
pref("network.http.sendSecureXSiteReferrer", false);
+pref("toolkit.telemetry.archive.enabled", false);
+pref("toolkit.telemetry.bhrPing.enabled", false);
pref("toolkit.telemetry.enabled", false);
pref("toolkit.telemetry.unified", false);
+pref("toolkit.telemetry.newProfilePing.enabled", false);
+pref("toolkit.telemetry.firstShutdownPing.enabled", false);
+pref("toolkit.telemetry.server", "127.0.0.1");
+pref("app.shield.optoutstudies.enabled", false);
+pref("experiments.enabled", false);
+pref("experiments.manifest.uri", "127.0.0.1");
+pref("extensions.pocket.enabled" : false);
+pref("extensions.pocket.api", "127.0.0.1");
// Do not tell what plugins do we have enabled: https://mail.mozilla.org/pipermail/firefox-dev/2013-November/001186.html
pref("plugins.enumerable_names", "");
pref("plugin.state.flash", 0);
@@ -511,8 +523,8 @@ END
for i in 16 22 24 32 48 64 128 192 256 384; do
rsvg-convert -w $i -h $i "$srcdir/$pkgname-$_bver/branding/${pkgname}_icon.svg" \
- -o "$srcdir/$pkgname-$_bver/default$i.png"
- install -Dm644 "$srcdir/$pkgname-$_bver/default$i.png" \
+ -o "browser/branding/iceweasel/default$i.png"
+ install -Dm644 "browser/branding/iceweasel/default$i.png" \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
done
@@ -523,7 +535,7 @@ END
"$pkgdir/usr/share/applications/$pkgname.desktop"
# Use system-provided dictionaries
- rm -r "$pkgdir"/usr/lib/$pkgname/dictionaries
+ rm -r "$pkgdir/usr/lib/$pkgname/dictionaries"
ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"