summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2024-02-19 08:30:34 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2024-02-21 20:09:19 -0500
commitae77838d8a7333b200a19a0c7271a214060f3a4d (patch)
treeba0206d298e650e06315ed7ad4c20b968491c106 /libre/iceweasel/PKGBUILD
parent510f4ecc03792dd39aadab3c78c5a81b88c6488a (diff)
iceweasel: upgrade to v122.0.1
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index fcfa8c107..ab19583fa 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -70,7 +70,7 @@
pkgname=iceweasel
epoch=1
-pkgver=122.0
+pkgver=122.0.1
pkgrel=1
pkgrel+=.parabola1
_brandingver=120.0
@@ -177,7 +177,7 @@ validpgpkeys+=(
'3954A7AB837D0EA9CFA9798925DB7D9B5A8D4B40' # bill-auger
)
-sha256sums=('b84815a90e147965e4c0b50599c85b1022ab0fce42105e5ef45c630dcca5dec3'
+sha256sums=('36f19c9a748eec2fd6d3a1594d0f1d7b715eaa1d9ed6d7eeda9db8478dcf36d6'
'SKIP'
'9cdc2602661717712092d28bb494e5b48e518cb930898aca85eaf21f91f7ef58') # $pkgname.desktop
# identity-icons-brand.svg
@@ -194,7 +194,7 @@ sha256sums_i686=('62fa060e09b95e92fa81f4ac47c06b03d70c2bbc6cda061d85e965a82730e1
'ed3bb281697af7c4353a34067ffb4b18a971d40757bef2d6af3c8bf2d28d42d1' # firefox-111.0.1-fdlibm.patch
'2fb39374fd3d80eea9e346032a2a4b2bc2e357dee7380855b24bcf19b1335d06' # fix-i686-build-moz-1792159.patch
'c3ce181fbb0142055aa6dd17f3cda2ba6a1e54d7a689a8c6e9cce76aa40e6544') # fix-i686-xsimd-incomplete.patch
-b2sums=('7252cd58fef9f5fcb504c8c9f885567109c05e6ec92157459cc384edc6935adb206e3be0b805aeaa37dbd72656c3243db1291b745dd0f705f37a61319a4dc820'
+b2sums=('ea4346b88c7f3e7e2126eed6b0f4b1460e70fa430944a7263d42ac762e10c8440967ebbae25ceff15e7afb451e1a890ab7e97ff60619a465152e9ff6a7691653'
'SKIP'
'f86353bbba05d8994db34c6abb66094aa61d2c37c8599930dbe9d215413f0f718a1ce55a8f2d07a65074c3947e28fc80d44c925bd9be239a870f82d2a1803635') # $pkgname.desktop
# identity-icons-brand.svg
@@ -235,7 +235,7 @@ readonly _SKIP_PGO=$(case "${CARCH}" in armv7h|i686) echo 1 ;; *) echo 0 ;; esac
# use GCC vs LLVM
# trying one or the other, may resolve sporadic compiler/linker discrepancies
-readonly _USE_ALT_COMPILER=$(case "${CARCH}" in armv7h) echo 1 ;; *) echo 0 ;; esac)
+readonly _USE_ALT_COMPILER=$(case "${CARCH}" in armv7h) echo 0 ;; *) echo 0 ;; esac)
# use 'bfd' linker vs 'lld'
# most significantly, this also disables LTO and debugging
@@ -507,7 +507,6 @@ END
# https://bugzilla.redhat.com/show_bug.cgi?id=1641623
echo "ac_add_options --disable-av1" >> .mozconfig
# reduce jobs due to RAM constraints
- MAKEFLAGS="-j1"
MAKEFLAGS="-j4"
# disable hard-coded LTO
sed -i '/cargo_rustc_flags += -Clto/d' config/makefiles/rust.mk
@@ -729,14 +728,12 @@ build() {
export CFLAGS+=" -g0"
export CXXFLAGS+=" -g0"
export LDFLAGS+=" -Wl,--no-keep-memory"
- export RUSTFLAGS="-Cdebuginfo=0"
+ export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"
# clang-16: warning: argument unused during compilation: '-fstack-clash-protection' [-Wunused-command-line-argument]
export CFLAGS+=' -Wno-unused-command-line-argument'
export CXXFLAGS+=' -Wno-unused-command-line-argument'
-
- # FTBS with LLVM:
if ! (( _USE_ALT_COMPILER ))
then # warning: obj/dist/system_wrappers/cmath:3:15: fatal error: 'cmath' file not found
export CFLAGS+=" -I/usr/include/c++/12.1.0 -I/usr/include/c++/12.1.0/armv7l-unknown-linux-gnueabihf"