summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-08-23 14:52:28 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-08-23 16:05:22 -0400
commitd4d8c2dac57f6a530dfb9b083e77ff27f264eb6a (patch)
treeec08fb516a34d0cbc8df09f3bf3594349da97479 /libre/iceweasel/PKGBUILD
parent37021d4a81bdd37541a1cc2606aa8a5f3e0114ca (diff)
libre/iceweasel: Make `makepkg -o` idempotent
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index a379819d8..9ad813a61 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -51,12 +51,12 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
options=(!emptydirs !makeflags !strip)
replaces=("$_pkgname")
conflicts=("$_pkgname")
-# https://archive.mozilla.org/pub/firefox/releases/$pkgver/SOURCE
-source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
+_repo=https://hg.mozilla.org/mozilla-unified
+source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
$pkgname.desktop)
source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}-${_brandingrel}.branding.tar.xz{,.sig}
libre.patch)
-sha256sums=('0bdecbbb2a955c9f4c5cd0b33acd1e47afcb6cd57ac89cf11257668e3cef202c'
+sha256sums=('SKIP'
'ed350ef2f528b999a621f7080fa80948be6b351e67ce32529fb32bcf47bb21fa'
'dabd5a0b8023e8ca13f6ae5fcb9e6c29531fc952bc781b4aa25c8a598187768e'
'SKIP'
@@ -64,7 +64,7 @@ sha256sums=('0bdecbbb2a955c9f4c5cd0b33acd1e47afcb6cd57ac89cf11257668e3cef202c'
validpgpkeys=('BFA8008A8265677063B11BF47171986E4B745536') # Andreas Grapentin
prepare() {
- cd firefox-$pkgver
+ cd mozilla-unified
cat >.mozconfig <<END
ac_add_options --enable-application=browser
@@ -111,9 +111,10 @@ END
# perform rebranding
local brandingdir="$srcdir/$pkgname-$_brandingver"
- mkdir -v browser/branding/$pkgname
- cp -va $brandingdir/branding/* browser/branding/$pkgname
+ rm -rf -- browser/branding/$pkgname
+ cp -aT -- $brandingdir/branding browser/branding/$pkgname
+ rm -rf .pc
export QUILT_PATCHES=$brandingdir/patches
export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
export QUILT_DIFF_ARGS='--no-timestamps'
@@ -147,8 +148,8 @@ END
cat browser/base/content/abouthome/aboutHome.xhtml > browser/base/content/newtab/newTab.xhtml
# Load our searchplugins
- rm -rv browser/locales/searchplugins
- cp -av /usr/lib/mozilla/searchplugins browser/locales
+ rm -rf -- browser/locales/searchplugins
+ cp -aT -- /usr/lib/mozilla/searchplugins browser/locales/searchplugins
# Disable various components at the source level
sed -i 's/;1/;0/' toolkit/components/telemetry/TelemetryStartup.manifest
@@ -158,7 +159,7 @@ END
}
build() {
- cd firefox-$pkgver
+ cd mozilla-unified
export MOZ_SOURCE_REPO="$_repo"
@@ -167,7 +168,7 @@ build() {
}
package() {
- cd firefox-$pkgver
+ cd mozilla-unified
DESTDIR="$pkgdir" ./mach install
find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +