summaryrefslogtreecommitdiff
path: root/libre/libquicktime-libre/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-06-22 17:33:58 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-06-22 17:33:58 -0300
commitbc42c16bdd4b5448c3f311637da8ad1f3c2b96cd (patch)
treec53fb7e21020824ef8c8af3137dba2aaa7dcbfa4 /libre/libquicktime-libre/PKGBUILD
parent41d8cd60318793b57e9db474f34506d7639380f4 (diff)
libquicktime-libre-1.2.2-3
Diffstat (limited to 'libre/libquicktime-libre/PKGBUILD')
-rw-r--r--libre/libquicktime-libre/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/libre/libquicktime-libre/PKGBUILD b/libre/libquicktime-libre/PKGBUILD
new file mode 100644
index 000000000..c6e4ab588
--- /dev/null
+++ b/libre/libquicktime-libre/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Mateusz Herych <heniekk@gmail.com>
+
+pkgname=libquicktime-libre
+_pkgname=libquicktime
+pkgver=1.2.2
+pkgrel=3
+pkgdesc="A library for reading and writing quicktime files (no unfree faac support)."
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://libquicktime.sourceforge.net/"
+depends=('gtk2' 'ffmpeg' 'alsa-lib' 'libxv' 'libgl' 'libxaw' 'x264' 'faad2')
+options=('!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('a83ddaaeaf98231d9f224190dcb8810ebdabd3edb5c8cebe2fb083d25edb7436')
+provides=("$_pkgname=$pkgver")
+conflicts=($_pkgname)
+replaces=($_pkgname)
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --enable-gpl \
+ --with-ffmpeg \
+ --with-x264 \
+ --without-doxygen
+ make
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+