summaryrefslogtreecommitdiff
path: root/libre/libretools/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2024-03-31 05:22:13 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2024-04-05 17:16:49 -0400
commit5d5ee6bfbbb9793e2819ad93b54a3ca0d9ed0e8d (patch)
tree6198ee43bbfdffd1f83e35c7627b539def8ab09d /libre/libretools/PKGBUILD
parent48ae8e8a68d4d982679b312754c14754e4045b40 (diff)
libretools: rebuild nonsystemd for pacman 6.1
preparing for merge/rebase nonsystemd->libre * synchronize/normalize libre and nonsystemd PKGBUILDs * remove ancient/obsolete depends/provides
Diffstat (limited to 'libre/libretools/PKGBUILD')
-rw-r--r--libre/libretools/PKGBUILD65
1 files changed, 33 insertions, 32 deletions
diff --git a/libre/libretools/PKGBUILD b/libre/libretools/PKGBUILD
index aeb4b510d..5b4d02fcb 100644
--- a/libre/libretools/PKGBUILD
+++ b/libre/libretools/PKGBUILD
@@ -4,28 +4,19 @@
# Contributor: Márcio Silva <coadde@hyperbola.info>
# Contributor: bill-auger <bill-auger@programmer.net>
-# Upstream information
pkgbase=libretools
pkgname=(libretools librelib gitget)
-pkgdesc="Programs for Parabola development"
-url="https://git.parabola.nu/packages/libretools.git/"
-license=('GPL3' 'GPL2')
-
pkgver=20240403
-source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz{,.sig})
-sha256sums=('210fecb2c5113818c685e90dc7e67f0f64995142cecc5eed1ac1284589d5840e'
- 'SKIP')
-validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9' # Luke Shumaker
- 'BFA8008A8265677063B11BF47171986E4B745536' # Andreas Grapentin
- '3954A7AB837D0EA9CFA9798925DB7D9B5A8D4B40') # bill-auger
-
-# Package information
-
+_pacman_constraints=( 'pacman<6.2' )
pkgrel=1
+pkgdesc="Programs for Parabola development"
arch=('any')
+url="https://git.parabola.nu/packages/libretools.git/"
+# license=(GPL-2.0-only GPL-3.0-or-later) # TODO:
+license=('GPL2' 'GPL3')
+
makedepends=(ruby-ronn-ng)
-_pacman_constraints=('pacman>=6.1' 'pacman<6.2')
checkdepends=(
bats
git
@@ -36,15 +27,23 @@ checkdepends=(
tokyocabinet
)
-# Build instructions
+source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz{,.sig})
+sha256sums=('210fecb2c5113818c685e90dc7e67f0f64995142cecc5eed1ac1284589d5840e'
+ 'SKIP')
+validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9' # Luke Shumaker
+ '6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
+ 'BFA8008A8265677063B11BF47171986E4B745536' # Andreas Grapentin
+ '3954A7AB837D0EA9CFA9798925DB7D9B5A8D4B40') # bill-auger
build() {
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir"/$pkgbase-$pkgver
+
make
}
check() {
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir"/$pkgbase-$pkgver
+
SUDO_USER= make check BATS_FLAGS='--filter-tags !network,!sudo'
}
@@ -57,7 +56,8 @@ package_librelib() {
'wget: for libreblacklist/blacklist.sh'
)
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir"/$pkgbase-$pkgver
+
make install-librelib DESTDIR="$pkgdir"
}
@@ -66,11 +66,8 @@ package_gitget() {
license=(GPL2)
depends=("librelib=$pkgver" git)
- provides=("libregit=$pkgver")
- conflicts=("libregit")
- replaces=("libregit")
+ cd "$srcdir"/$pkgbase-$pkgver
- cd "$srcdir/$pkgbase-$pkgver"
make install-gitget DESTDIR="$pkgdir"
}
@@ -80,31 +77,35 @@ package_libretools() {
etc/libretools.d/libredbdiff.conf
etc/libretools.d/librefetch.conf)
install=libretools.install
- conflicts=(devtools libretools-mips64el)
- replaces=(libretools-mips64el)
+ conflicts=(devtools)
depends=(
- "librelib=$pkgver"
- "gitget=$pkgver" # `createworkdir`
- "${_pacman_constraints[@]}"
arch-install-scripts # `mkarchroot` uses `pacstrap`
binutils # `libremakepkg`->`makepkg` uses `strip`
expac # `libredbdiff`
fakeroot # `libremakepkg`->`makepkg` uses `fakeroot`
make # `librefetch`
openssh # `librerelease`
- #pacutils # `librechroot` uses `pacsift` # not yet, it doesn't
+ pacutils # `librechroot` uses `pacsift`
rsync # `librerelease` and `makechrootpkg.sh`
- 'systemd-tools>=234' # `systemd-nspawn` # TODO: nonsystemd `chroot-run`
tokyocabinet # `toru`
- #namcap # `libremakepkg` # Namcap is currently disabled in libremakepkg :-(
+ namcap # `libremakepkg`
subversion # `diff-unfree`
wget # `aur`, optdepend for librelib:`blacklist`
)
+ depends+=( # pinned dependencies
+ "librelib=$pkgver"
+ "gitget=$pkgver" # `createworkdir`
+ "${_pacman_constraints[@]}"
+ 'systemd-tools>=234' # `systemd-nspawn` # TODO: merge 'nonsystemd' branch
+ )
+ depends=( ${depends[*]/pacutils/} ) # WIP
+ depends=( ${depends[*]/namcap/} ) # FIXME: Namcap is currently disabled in libremakepkg :-(
optdepends=(
'qemu-user-static-binfmt: To build ARM packages from x86'
)
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir"/$pkgbase-$pkgver
+
make install-libretools DESTDIR="$pkgdir"
}