summaryrefslogtreecommitdiff
path: root/libre/libretools/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-04-18 00:16:26 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-04-18 00:18:12 -0400
commitf55047c88ab14cc84d1dbcdadc7eb756810968e5 (patch)
treeed9020f6a6e7e70024a840819836f51096711ebc /libre/libretools/PKGBUILD
parentf8e727bc7c3378712db31138154e5b9727bc21b9 (diff)
update libre/libretools
Diffstat (limited to 'libre/libretools/PKGBUILD')
-rw-r--r--libre/libretools/PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/libre/libretools/PKGBUILD b/libre/libretools/PKGBUILD
index 0adae2d87..b7f432d71 100644
--- a/libre/libretools/PKGBUILD
+++ b/libre/libretools/PKGBUILD
@@ -9,11 +9,11 @@ pkgdesc="Programs for Parabola development"
url="https://projects.parabola.nu/packages/libretools.git/"
license=('GPL3' 'GPL2')
-pkgver=20160208
+pkgver=20160418
source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('a8b1a34b575f559a70cdcba0a4ded64f')
+md5sums=('449752708f874704a4a06ad979b0f0dd')
-pkgrel=2
+pkgrel=1
arch=('any')
makedepends=(emacs ruby-ronn) # emacs --batch is used during the build to process text
checkdepends=(sh-roundup git)
@@ -32,8 +32,9 @@ check() {
package_librelib() {
pkgdesc="The shell library portion of libretools"
license=(GPL2)
- depends=(
- wget # `blacklist`
+ optdepends=(
+ 'libretools: for libreblacklist/blacklist.sh'
+ 'wget: for libreblacklist/blacklist.sh'
)
cd "$srcdir/$pkgbase-$pkgver"
@@ -79,16 +80,16 @@ package_libretools() {
depends=(
"librelib=$pkgver"
"xbs=$pkgver" # `createworkdir`, `librestage`
- 'pacman>=5.0.0' 'pacman<5.1'
+ 'pacman>=5.0.1-2.parabola4' 'pacman<5.1'
arch-install-scripts # `mkarchroot` uses `pacstrap`
make # `librefetch`
openssh # `librerelease`
rsync # `librerelease` and `makechrootpkg.sh`
systemd # systemd-nspawn
tokyocabinet # `toru`
- #namcap # Namcap is currently dissabled in libremakepkg :(
+ #namcap # Namcap is currently dissabled in libremakepkg :-(
#subversion # `diff-unfree` # ignore because of xbs
- #wget # `aur` # ignore because of librelib
+ wget # `aur`, optdepend for librelib:`blacklist`
)
cd "$srcdir/$pkgbase-$pkgver"