summaryrefslogtreecommitdiff
path: root/libre/licenses-libre/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2011-01-27 04:58:12 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2011-01-27 04:58:12 -0300
commit5e3df826584c6dbde610119dfdcb687fd0b8d316 (patch)
treec300d7f0c61aa4149aa105d299ea6e062201a3b1 /libre/licenses-libre/PKGBUILD
parentab2491fc0cea3813522bbd8945930711f6b269ff (diff)
licenses-libre-2.6-1
Diffstat (limited to 'libre/licenses-libre/PKGBUILD')
-rw-r--r--libre/licenses-libre/PKGBUILD114
1 files changed, 114 insertions, 0 deletions
diff --git a/libre/licenses-libre/PKGBUILD b/libre/licenses-libre/PKGBUILD
new file mode 100644
index 000000000..574fe6d84
--- /dev/null
+++ b/libre/licenses-libre/PKGBUILD
@@ -0,0 +1,114 @@
+# $Id: PKGBUILD 82120 2010-06-08 16:36:51Z dan $
+# Maintainer: Dan McGee <dan@archlinux.org>
+# Maintainer (Parabola): fauno <fauno@kiwwwi.com.ar>
+
+pkgname=licenses-libre
+pkgver=2.6
+pkgrel=1
+pkgdesc="The standard licenses distribution package"
+arch=('any')
+license=('custom:none')
+url="http://parabolagnulinux.org"
+groups=('base')
+provides=("licenses=${pkgver}")
+conflicts=('licenses')
+replaces=('licenses')
+source=(apache-2.0.txt::http://www.apache.org/licenses/LICENSE-2.0.txt
+ cc-by-3.0.txt
+ cc-by-sa-3.0.txt
+ cc-readme.txt
+ cddl-1.0.txt
+ eclipse-1.0.txt
+ http://www.gnu.org/licenses/gpl-2.0.txt
+ http://www.gnu.org/licenses/gpl-3.0.txt
+ http://www.gnu.org/licenses/lgpl-2.1.txt
+ http://www.gnu.org/licenses/lgpl-3.0.txt
+ http://www.gnu.org/licenses/fdl-1.2.txt
+ http://www.gnu.org/licenses/fdl-1.3.txt
+ http://www.latex-project.org/lppl.txt
+ http://www.mozilla.org/MPL/MPL-1.1.txt
+ perlartistic.txt
+ php-3.0.txt::http://www.php.net/license/3_0.txt
+ ruby-license.txt::http://www.ruby-lang.org/en/LICENSE.txt
+ cpl-1.0.txt
+ python-2.txt
+ ZopePublicLicense.txt)
+md5sums=('3b83ef96387f14655fc854ddc3c6bd57'
+ 'ffb24d1bbf8b83d373f0b8edc3feb0c6'
+ '5367190077e12a7f55403d531ef3998e'
+ '77651e5c686cbc0f8cec5ac7e6504235'
+ '6cb35f3976cd093011967fa1abbce386'
+ 'f300afd598546add034364cd0a533261'
+ 'b234ee4d69f5fce4486a80fdaf4a4263'
+ 'd32239bcb673463ab874e80d47fae504'
+ '4fbd65380cdd255951079008b364516c'
+ 'e6a600fd5e1d9cbde2d983680233ad02'
+ '24ea4c7092233849b4394699333b5c56'
+ '10b9de612d532fdeeb7fe8fcd1435cc6'
+ '9f4337828d782bdea41f03dd2ad1b808'
+ 'bfe1f75d606912a4111c90743d6c7325'
+ 'd09c120ca7db95ef2aeecec0cb08293b'
+ 'a45bb1bbeed9e26b26c5763df1d3913d'
+ '68d59ff8306e3a9f5f1c01462c77a317'
+ 'f083e41c43db25e18f36c91e57750b64'
+ 'a055911c32fb4ed6e96c453ceaeba857'
+ 'dc8502850eab9e1ff330a12d7ca18a19')
+
+build() {
+ cd $pkgdir
+ mkdir -p usr/share/licenses/common
+ cd usr/share/licenses/common
+
+ mkdir APACHE
+ cp $srcdir/apache-2.0.txt APACHE/license.txt
+
+ mkdir CCPL
+ cp $srcdir/cc-by-3.0.txt CCPL/
+ cp $srcdir/cc-by-sa-3.0.txt CCPL/
+ cp $srcdir/cc-readme.txt CCPL/
+
+ mkdir CDDL
+ cp $srcdir/cddl-1.0.txt CDDL/license.txt
+
+ mkdir CPL
+ cp $srcdir/cpl-1.0.txt CPL/license.txt
+
+ mkdir EPL
+ cp $srcdir/eclipse-1.0.txt EPL/license.txt
+
+ mkdir {GPL2,GPL3}
+ cp $srcdir/gpl-2.0.txt GPL2/license.txt
+ cp $srcdir/gpl-3.0.txt GPL3/license.txt
+ ln -s GPL2 GPL
+
+ mkdir {FDL1.2,FDL1.3}
+ cp $srcdir/fdl-1.2.txt FDL1.2/license.txt
+ cp $srcdir/fdl-1.3.txt FDL1.3/license.txt
+ ln -s FDL1.2 FDL
+
+ mkdir {LGPL2.1,LGPL3}
+ cp $srcdir/lgpl-2.1.txt LGPL2.1/license.txt
+ cp $srcdir/lgpl-3.0.txt LGPL3/license.txt
+ ln -s LGPL2.1 LGPL
+
+ mkdir LPPL
+ cp $srcdir/lppl.txt LPPL/license.txt
+
+ mkdir MPL
+ cp $srcdir/MPL-1.1.txt MPL/license.txt
+
+ mkdir PerlArtistic
+ cp $srcdir/perlartistic.txt PerlArtistic/license.txt
+
+ mkdir PHP
+ cp $srcdir/php-3.0.txt PHP/license.txt
+
+ mkdir PSF
+ cp $srcdir/python-2.txt PSF/license.txt
+
+ mkdir RUBY
+ cp $srcdir/ruby-license.txt RUBY/license.txt
+
+ mkdir ZPL
+ cp $srcdir/ZopePublicLicense.txt ZPL/license.txt
+}