summaryrefslogtreecommitdiff
path: root/libre/linux-libre-pck/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2019-12-08 15:48:08 -0300
committerDavid P <megver83@parabola.nu>2019-12-08 15:48:08 -0300
commit22bc66c340be8d6fa4a246314fcc476cb55a80eb (patch)
tree6bcd63854e9e75a71cd3a7e10b5285aa6e5c4744 /libre/linux-libre-pck/PKGBUILD
parent013e53ef280865b7fd000bbefec9e7d7c3aabef0 (diff)
updpkg: libre/linux-libre-pck 5.4.2.pck1-1
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/linux-libre-pck/PKGBUILD')
-rw-r--r--libre/linux-libre-pck/PKGBUILD75
1 files changed, 36 insertions, 39 deletions
diff --git a/libre/linux-libre-pck/PKGBUILD b/libre/linux-libre-pck/PKGBUILD
index bac90f957..fcb24b6d1 100644
--- a/libre/linux-libre-pck/PKGBUILD
+++ b/libre/linux-libre-pck/PKGBUILD
@@ -14,41 +14,41 @@ _replacesoldkernels=()
_replacesoldmodules=()
pkgbase=linux-libre-pck
-_srcbasever=5.3-gnu
-_srcver=5.3.8-gnu
-_srcname=linux-${_srcbasever%-*}
-_pckrel=1
-pkgver=${_srcver//-/.${_pckrel}_}
+pkgver=5.4.2.pck1
pkgrel=1
+pkgdesc='Linux-libre PCK'
url='https://wiki.parabola.nu/PCK'
arch=(i686 x86_64 armv7h)
license=(GPL2)
makedepends=(
- xmlto kmod inetutils bc libelf
- python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+ bc kmod libelf
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
)
options=('!strip')
+_srcname=linux-5.4
source=(
- "https://linux-libre.fsfla.org/pub/linux-libre/releases/$_srcbasever/linux-libre-$_srcbasever.tar.xz"{,.sign}
- "https://linux-libre.fsfla.org/pub/linux-libre/releases/$_srcver/patch-$_srcbasever-$_srcver.xz"{,.sign}
- "https://repo.parabola.nu/other/pck/patches/$_srcver/patch-$_srcver-pck$_pckrel.patch"{,.sig}
+ "https://linux-libre.fsfla.org/pub/linux-libre/releases/${_srcname##*-}-gnu/linux-libre-${_srcname##*-}-gnu.tar.xz"{,.sign}
+ "https://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver%.*}-gnu/patch-${_srcname##*-}-gnu-${pkgver%.*}-gnu.xz"{,.sign}
+ "https://repo.parabola.nu/other/pck/patches/${pkgver%.*}-gnu/patch-${pkgver%.*}-gnu-${pkgver##*.}.patch"{,.sig}
config.i686 config.x86_64 config.armv7h # the main kernel config files
linux-armv7h.preset # armv7h preset file for mkinitcpio ramdisk
+ "revert.diff::https://github.com/zen-kernel/zen-kernel/commit/92f669d8f5542fe3981115706a7b9066a0903b4a.patch"
)
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
)
-sha512sums=('85d83c973ef96ab414354414da70ab3e1c3df19c3088458498cec1594952878b7967a8988bd9e36d4e728cc573a36e6eac056dbcab2f9aa742f18cbb4fb3164f'
+sha512sums=('0d0915133864eb031adfc6700066147dcf3e768a50a31c39754950c95ef4fd322dc701cd50af49c403ef0325adfcb07e354d5e46c1be3dcdd719a7a55c963f37'
'SKIP'
- 'eca168c4c460bf8d8fbf322e1aa9c6b509f205c7597142967648c09402de95c8438ae302b4920c8f120192b1a54286f0fb860955c66414f3a3c376e41f246391'
+ '0b177b5ab5e7b65769c7b1176590f9fadd134f32af4db2bd0fa362dccfefb28d7fd0865b46418f54f10f039623d86012b49bcfb968bae77274447d7a97da35f5'
'SKIP'
- '79cec6e5ff5da8c54757f770ae9fa2a0f27c00d7c913c7466ccc69fdda3f62f5526886893253fb98279583848fbce244fc7cb86086d88b2d74305caf86c4a631'
+ '7f935c09c0d46ac1925dba45616962d4e73cad4eeaef4af3565915eeafbe853afd90faae9f6cd567b7a71b910512d43da0649d578a01e2d740cc7b1eb1a4e192'
'SKIP'
- '1e6d25562aaf9faabc44f7b4d9a392f236371913f09a74d1d1c04dda7857b0ebfc0743ce6bd772b4eb2c25caf3ba90ab1fc1e9336e18bb912dc20ae2b300dc66'
- '74b3360256b49f918129a2d543ccbb92e28e68203ca0907aadbcb605f86db13010260898dc0f1148214638433888e5e7d8d56f5b4046c3254289a84de4f72b88'
- '9e9184bc047fa1dd9341eca6d0ea334a1fde051e3126b1bb5537e23125e630c034c806ef104f28cd01a783620b026e0519b9c98c0bd8a79be748d1c9890193e3'
- 'aca591b5a2e838754e3c5fd2c0e50098ad54c2d0f990de5bf9cff8608e881daf0e37132294ed1a0e0a7b9e1c194c0b89f95da001d94febdb25a01c409060e3ac')
+ 'ffaee50ee6400dd664e2486504e491e6a023b97a4234faea96c98013cb8fd3a813aca5cc97c5f909180acc22137bb51fd083c9f66a3e08a1e1b62d1b752f6ae4'
+ 'e72735acf8502219a6f420ce3fab7cfba76c7460d46cf390366b39988bb45cddc4aa9b65257b4f6fae8b59f7f1f1d4bdc877246fa20c4e43bdd44f5f85d027c5'
+ '82c1f245ce87d41f85e249c6be36f66b5949a803604af1502bb6d74ab059e636f15ffd1365564f91bc6d539f8afdf3558fe6dcb03459f8d47174ba2ead825ed2'
+ 'f01e7925b262d2874a8a991b1f27d057356a2a384d2012b61be5a631d4e4d7cf87461c8fb9e7f183831f5a829ad204897f1f0545a52df6288a0e04a5c2e31b96'
+ '09de09b3333f631d2ecfd8c2bc8798dde3d88eb822f4032fa3152c8498588236f38ad29ba118dc29309a7b3783fb6c89dd3f4daa78ee6d1b24437076fcf479f2')
_replacesarchkernel=("${_replacesarchkernel[@]/\%/${pkgbase#linux-libre}}")
_replacesoldkernels=("${_replacesoldkernels[@]/\%/${pkgbase#linux-libre}}")
@@ -61,14 +61,14 @@ esac
export KBUILD_BUILD_HOST=parabola
export KBUILD_BUILD_USER=$pkgbase
-export KBUILD_BUILD_TIMESTAMP="@${SOURCE_DATE_EPOCH:-$(date +%s)}"
+export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
prepare() {
cd $_srcname
- # add upstream patch
- if [ "$_srcbasever" != "$_srcver" ]; then
- patch -p1 -i ../patch-$_srcbasever-$_srcver
+ if [ "${_srcname##*-}" != "${pkgver%.*}" ]; then
+ msg2 "Applying upstream patch..."
+ patch -Np1 -i ../patch-${_srcname##*-}-gnu-${pkgver%.*}-gnu
fi
msg2 "Setting version..."
@@ -85,6 +85,11 @@ prepare() {
patch -Np1 < "../$src"
done
+ if [ "$CARCH" = "armv7h" ]; then
+ # this breaks the build in GCC 8.3.0
+ patch -NRp1 -i ../revert.diff
+ fi
+
msg2 "Setting config..."
cp ../config.$CARCH .config
make olddefconfig
@@ -103,11 +108,11 @@ build() {
}
_package() {
- pkgdesc="The ${pkgbase^} kernel and modules with a handful of awesome features not merged into mainline [AUFS, BFQ, BFS, UKSM]"
+ pkgdesc="The $pkgdesc kernel and modules"
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-libre-firmware: firmware images needed for some devices')
- provides=("${_replacesarchkernel[@]/%/=${_srcver%%-*}}" "LINUX-ABI_VERSION=${_srcver%%-*}")
+ provides=("${_replacesarchkernel[@]/%/=${pkgver//pck/zen}}" "LINUX-ABI_VERSION=${pkgver%.*}")
conflicts=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
replaces=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
@@ -146,8 +151,8 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for ${pkgbase^} kernel"
- provides=("${_replacesarchkernel[@]/%/-headers=${_srcver%%-*}}")
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ provides=("${_replacesarchkernel[@]/%/-headers=${pkgver//pck/zen}}")
conflicts=("${_replacesarchkernel[@]/%/-headers}" "${_replacesoldkernels[@]/%/-headers}")
replaces=("${_replacesarchkernel[@]/%/-headers}" "${_replacesoldkernels[@]/%/-headers}")
@@ -248,8 +253,8 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase^} kernel"
- provides=("${_replacesarchkernel[@]/%/-docs=${_srcver%%-*}}")
+ pkgdesc="Documentation for the $pkgdesc kernel"
+ provides=("${_replacesarchkernel[@]/%/-docs=${pkgver//pck/zen}}")
conflicts=("${_replacesarchkernel[@]/%/-docs}" "${_replacesoldkernels[@]/%/-docs}")
replaces=("${_replacesarchkernel[@]/%/-docs}" "${_replacesoldkernels[@]/%/-docs}")
@@ -257,20 +262,12 @@ _package-docs() {
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
msg2 "Installing documentation..."
- mkdir -p "$builddir"
- cp -t "$builddir" -a Documentation
-
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
local src dst
while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
+ dst="${src#Documentation/}"
+ dst="$builddir/Documentation/${dst#output/}"
+ install -Dm644 "$src" "$dst"
+ done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"